Paroxe.PdfRenderer Namespace

PDF Renderer
Paroxe.PdfRenderer Namespace
Classes
 | Class | Description
Public class | PDFAction | Represents the PDF action into a PDF document.
Public class | PDFActionHandlerHelper | Provides default action handling implementation.
Public class | PDFAsset | For internal use only.
Public class | PDFBookmark | Represents the bookmark into a PDF document.
Public class | PDFDest | Represents a destination into a PDF document.
Public class | PDFDocument | Represents a PDF document. This class is the entry point of all functionalities.
Public class | PDFLibrary | Contains GetLastError() function
Public class | PDFLink | Represents the annotation link in a PDF page.
Public class | PDFPage | Represents a PDF page inside document.
Public class | PDFProgressiveSearch | Don't instantiate this class directly. Use the static method instead PDFProgressiveSearch.CreateSearch
Public class | PDFRenderer | This class allow the application to render pages into textures.
Public class | PDFRendererRenderSettings | Allows the application to specify render settings.
Public class | PDFSearchHandle | Represent a search session within a specific page. To search in entire document use PDFTextPage.Search
Public class | PDFTextPage | This class allow to access the text of a page.
Public class | PDFViewer | PDFViewer is an Unity UI component that allow you to visualize PDF Document.
Structures
 | Structure | Description
Public structure | PDFColoredRect | Represent a colored rect within a page. This class is used mainly for search results highlightment. Will maybe used for text selection in the future.
Public structure | PDFSearchResult | Reprensent a search result. To result location is describe with index of the first char and the length of the result.
Interfaces
 | Interface | Description
Public interface | IPDFColoredRectListProvider | This interface allow to implement a custome colorec rects provider. For example, PDFViewer inherits this class and implements it to provide colorect rects during a search session to the renderer.
Public interface | IPDFDevice | Interface for device implementation. PDFViewer implements it. It allows to decouple PDFViewer from the API
Public interface | IPDFDeviceActionHandler | Implement this class to provide a custom action handling stategy. For example, PDFViewer.BookmarksActionHandler and PDFViewer.LinksActionHandler both refer to a default implementation of this interface.
Delegates
 | Delegate | Description
Public delegate | PDFProgressiveSearchProgressEventHandler |
Public delegate | PDFProgressiveSearchSearchFinishedEventHandler |
Public delegate | PDFViewerCancelEventHandler |
Public delegate | PDFViewerCurrentPageChangedEventHandler |
Public delegate | PDFViewerDocumentChangedEventHandler |
Public delegate | PDFViewerLoadFailEventHandler |
Public delegate | PDFViewerPDFViewerEventHandler |
Public delegate | PDFViewerZoomChangedEventHandler |
Enumerations
 | Enumeration | Description
Public enumeration | PDFActionActionType |
Public enumeration | PDFLibraryErrorCode |
Public enumeration | PDFPagePageRotation | Rotations are clockwise
Public enumeration | PDFSearchHandleMatchOption |
Public enumeration | PDFViewerFileSourceType |
Public enumeration | PDFViewerPageFittingType |
Public enumeration | PDFViewerViewerModeType |
Send comments on this topic to contact.paroxe@gmail.com


IPDFColoredRectListProvider Interface

IPDFColoredRectListProvider Interface
This interface allow to implement a custome colorec rects provider. For example, PDFViewer inherits this class and implements it to provide colorect rects during a search session to the renderer.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public interface IPDFColoredRectListProvider

The IPDFColoredRectListProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetBackgroundColoredRectList |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace


IPDFColoredRectListProvider Methods

IPDFColoredRectListProvider Methods

The IPDFColoredRectListProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetBackgroundColoredRectList |
Top
See Also

Reference

IPDFColoredRectListProvider Interface


IPDFColoredRectListProvider.GetBackgroundColoredRectList Method

IPDFColoredRectListProviderGetBackgroundColoredRectList Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
IList<PDFColoredRect> GetBackgroundColoredRectList(
    PDFPage page
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage

Return Value

Type: IList PDFColoredRect
See Also

Reference

IPDFColoredRectListProvider Interface


IPDFDevice Interface

IPDFDevice Interface
Interface for device implementation. PDFViewer implements it. It allows to decouple PDFViewer from the API

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public interface IPDFDevice

The IPDFDevice type exposes the following members.

Properties
 | Name | Description
Public property | AllowOpenURL |
Public property | BookmarksActionHandler |
Public property | LinksActionHandler |
Top
Methods
 | Name | Description
Public method | GetDevicePageSize |
Public method | GetLoadedDocument |
Public method | GoToPage |
Public method | LoadDocument |
Public method | LoadDocumentFromAsset(PDFAsset, Int32) |
Public method | LoadDocumentFromAsset(PDFAsset, String, Int32) |
Public method | LoadDocumentFromResources |
Public method | LoadDocumentFromStreamingAssets |
Public method | LoadDocumentFromWeb |
Public method | LoadDocumentWithBuffer |
Public method | LoadDocumentWithFile |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


IPDFDevice Properties

IPDFDevice Properties

The IPDFDevice type exposes the following members.

Properties
 | Name | Description
Public property | AllowOpenURL |
Public property | BookmarksActionHandler |
Public property | LinksActionHandler |
Top
See Also

Reference

IPDFDevice Interface


IPDFDevice.AllowOpenURL Property

IPDFDeviceAllowOpenURL Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
bool AllowOpenURL { get; set; }

Property Value

Type: Boolean
See Also

Reference

IPDFDevice Interface


IPDFDevice.BookmarksActionHandler Property

IPDFDeviceBookmarksActionHandler Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
IPDFDeviceActionHandler BookmarksActionHandler { get; set; }

Property Value

Type: IPDFDeviceActionHandler
See Also

Reference

IPDFDevice Interface


IPDFDevice.LinksActionHandler Property

IPDFDeviceLinksActionHandler Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
IPDFDeviceActionHandler LinksActionHandler { get; set; }

Property Value

Type: IPDFDeviceActionHandler
See Also

Reference

IPDFDevice Interface


IPDFDevice Methods

IPDFDevice Methods

The IPDFDevice type exposes the following members.

Methods
 | Name | Description
Public method | GetDevicePageSize |
Public method | GetLoadedDocument |
Public method | GoToPage |
Public method | LoadDocument |
Public method | LoadDocumentFromAsset(PDFAsset, Int32) |
Public method | LoadDocumentFromAsset(PDFAsset, String, Int32) |
Public method | LoadDocumentFromResources |
Public method | LoadDocumentFromStreamingAssets |
Public method | LoadDocumentFromWeb |
Public method | LoadDocumentWithBuffer |
Public method | LoadDocumentWithFile |
Top
See Also

Reference

IPDFDevice Interface


IPDFDevice.GetDevicePageSize Method

IPDFDeviceGetDevicePageSize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
Vector2 GetDevicePageSize(
    int pageIndex
)

Parameters

pageIndex
Type: SystemInt32

Return Value

Type: Vector2
See Also

Reference

IPDFDevice Interface


IPDFDevice.GetLoadedDocument Method

IPDFDeviceGetLoadedDocument Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
PDFDocument GetLoadedDocument()

Return Value

Type: PDFDocument
See Also

Reference

IPDFDevice Interface


IPDFDevice.GoToPage Method

IPDFDeviceGoToPage Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void GoToPage(
    int pageIndex
)

Parameters

pageIndex
Type: SystemInt32
See Also

Reference

IPDFDevice Interface


IPDFDevice.LoadDocument Method

IPDFDeviceLoadDocument Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void LoadDocument(
    PDFDocument document,
    string password,
    int pageIndex
)

Parameters

document
Type: Paroxe.PdfRendererPDFDocument
password
Type: SystemString
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDevice Interface


IPDFDevice.LoadDocumentFromAsset Method

IPDFDeviceLoadDocumentFromAsset Method
Overload List
 | Name | Description
Public method | LoadDocumentFromAsset(PDFAsset, Int32) |
Public method | LoadDocumentFromAsset(PDFAsset, String, Int32) |
Top
See Also

Reference

IPDFDevice Interface


IPDFDevice.LoadDocumentFromAsset Method (PDFAsset, Int32)

IPDFDeviceLoadDocumentFromAsset Method (PDFAsset, Int32)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void LoadDocumentFromAsset(
    PDFAsset pdfAsset,
    int pageIndex
)

Parameters

pdfAsset
Type: Paroxe.PdfRendererPDFAsset
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDevice Interface
LoadDocumentFromAsset Overload


IPDFDevice.LoadDocumentFromAsset Method (PDFAsset, String, Int32)

IPDFDeviceLoadDocumentFromAsset Method (PDFAsset, String, Int32)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void LoadDocumentFromAsset(
    PDFAsset pdfAsset,
    string password,
    int pageIndex
)

Parameters

pdfAsset
Type: Paroxe.PdfRendererPDFAsset
password
Type: SystemString
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDevice Interface
LoadDocumentFromAsset Overload


IPDFDevice.LoadDocumentFromResources Method

IPDFDeviceLoadDocumentFromResources Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void LoadDocumentFromResources(
    string folder,
    string fileName,
    string password,
    int pageIndex
)

Parameters

folder
Type: SystemString
fileName
Type: SystemString
password
Type: SystemString
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDevice Interface


IPDFDevice.LoadDocumentFromStreamingAssets Method

IPDFDeviceLoadDocumentFromStreamingAssets Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void LoadDocumentFromStreamingAssets(
    string folder,
    string fileName,
    string password,
    int pageIndex
)

Parameters

folder
Type: SystemString
fileName
Type: SystemString
password
Type: SystemString
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDevice Interface


IPDFDevice.LoadDocumentFromWeb Method

IPDFDeviceLoadDocumentFromWeb Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void LoadDocumentFromWeb(
    string url,
    string password,
    int pageIndex
)

Parameters

url
Type: SystemString
password
Type: SystemString
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDevice Interface


IPDFDevice.LoadDocumentWithBuffer Method

IPDFDeviceLoadDocumentWithBuffer Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void LoadDocumentWithBuffer(
    byte[] buffer,
    string password,
    int pageIndex
)

Parameters

buffer
Type: SystemByte
password
Type: SystemString
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDevice Interface


IPDFDevice.LoadDocumentWithFile Method

IPDFDeviceLoadDocumentWithFile Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void LoadDocumentWithFile(
    string filePath,
    string password,
    int pageIndex
)

Parameters

filePath
Type: SystemString
password
Type: SystemString
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDevice Interface


IPDFDeviceActionHandler Interface

IPDFDeviceActionHandler Interface
Implement this class to provide a custom action handling stategy. For example, PDFViewer.BookmarksActionHandler and PDFViewer.LinksActionHandler both refer to a default implementation of this interface.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public interface IPDFDeviceActionHandler

The IPDFDeviceActionHandler type exposes the following members.

Methods
 | Name | Description
Public method | HandleGotoAction | Called when a goto action is triggered.
Public method | HandleLaunchAction | Called when a launch action is triggered.
Public method | HandleRemoteGotoActionPasswordResolving | Implement the function if you want to provide password. This method received the resolved path returned by the previous method (HandleRemoteGotoActionPathResolving)
Public method | HandleRemoteGotoActionPathResolving | Implement the function if you want custom path resolving before PDF Viewer open other pdf file. The method must return the modified filePath or just return the original filePath. See PDFViewerDefaultActionHandler class for the default implementation.
Public method | HandleRemoteGotoActionResolved | This method is called after the new pdf document is loaded but not yet opened in the pdfViewer. See PDFViewerDefaultActionHandler class for the default implementation.
Public method | HandleRemoteGotoActionUnresolved | This method is called when the pdf pdf file at filePath doesn't exists or is invalid.
Public method | HandleUnsuportedAction | Called when the action is unsuported
Public method | HandleUriAction | Called for action that point to an Uri (Universal Resource Identifier)
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


IPDFDeviceActionHandler Methods

IPDFDeviceActionHandler Methods

The IPDFDeviceActionHandler type exposes the following members.

Methods
 | Name | Description
Public method | HandleGotoAction | Called when a goto action is triggered.
Public method | HandleLaunchAction | Called when a launch action is triggered.
Public method | HandleRemoteGotoActionPasswordResolving | Implement the function if you want to provide password. This method received the resolved path returned by the previous method (HandleRemoteGotoActionPathResolving)
Public method | HandleRemoteGotoActionPathResolving | Implement the function if you want custom path resolving before PDF Viewer open other pdf file. The method must return the modified filePath or just return the original filePath. See PDFViewerDefaultActionHandler class for the default implementation.
Public method | HandleRemoteGotoActionResolved | This method is called after the new pdf document is loaded but not yet opened in the pdfViewer. See PDFViewerDefaultActionHandler class for the default implementation.
Public method | HandleRemoteGotoActionUnresolved | This method is called when the pdf pdf file at filePath doesn't exists or is invalid.
Public method | HandleUnsuportedAction | Called when the action is unsuported
Public method | HandleUriAction | Called for action that point to an Uri (Universal Resource Identifier)
Top
See Also

Reference

IPDFDeviceActionHandler Interface


IPDFDeviceActionHandler.HandleGotoAction Method

IPDFDeviceActionHandlerHandleGotoAction Method
Called when a goto action is triggered.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void HandleGotoAction(
    IPDFDevice device,
    int pageIndex
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDeviceActionHandler Interface


IPDFDeviceActionHandler.HandleLaunchAction Method

IPDFDeviceActionHandlerHandleLaunchAction Method
Called when a launch action is triggered.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void HandleLaunchAction(
    IPDFDevice device,
    string filePath
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
filePath
Type: SystemString
See Also

Reference

IPDFDeviceActionHandler Interface


IPDFDeviceActionHandler.HandleRemoteGotoActionPasswordResolving Method

IPDFDeviceActionHandlerHandleRemoteGotoActionPasswordResolving Method
Implement the function if you want to provide password. This method received the resolved path returned by the previous method (HandleRemoteGotoActionPathResolving)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
string HandleRemoteGotoActionPasswordResolving(
    IPDFDevice device,
    string resolvedFilePath
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
resolvedFilePath
Type: SystemString

Return Value

Type: String
See Also

Reference

IPDFDeviceActionHandler Interface


IPDFDeviceActionHandler.HandleRemoteGotoActionPathResolving Method

IPDFDeviceActionHandlerHandleRemoteGotoActionPathResolving Method
Implement the function if you want custom path resolving before PDF Viewer open other pdf file. The method must return the modified filePath or just return the original filePath. See PDFViewerDefaultActionHandler class for the default implementation.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
string HandleRemoteGotoActionPathResolving(
    IPDFDevice device,
    string filePath
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
filePath
Type: SystemString

Return Value

Type: String
See Also

Reference

IPDFDeviceActionHandler Interface


IPDFDeviceActionHandler.HandleRemoteGotoActionResolved Method

IPDFDeviceActionHandlerHandleRemoteGotoActionResolved Method
This method is called after the new pdf document is loaded but not yet opened in the pdfViewer. See PDFViewerDefaultActionHandler class for the default implementation.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void HandleRemoteGotoActionResolved(
    IPDFDevice device,
    PDFDocument document,
    int pageIndex
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
document
Type: Paroxe.PdfRendererPDFDocument
pageIndex
Type: SystemInt32
See Also

Reference

IPDFDeviceActionHandler Interface


IPDFDeviceActionHandler.HandleRemoteGotoActionUnresolved Method

IPDFDeviceActionHandlerHandleRemoteGotoActionUnresolved Method
This method is called when the pdf pdf file at filePath doesn't exists or is invalid.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void HandleRemoteGotoActionUnresolved(
    IPDFDevice device,
    string resolvedFilePath
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
resolvedFilePath
Type: SystemString
See Also

Reference

IPDFDeviceActionHandler Interface


IPDFDeviceActionHandler.HandleUnsuportedAction Method

IPDFDeviceActionHandlerHandleUnsuportedAction Method
Called when the action is unsuported

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void HandleUnsuportedAction(
    IPDFDevice device
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
See Also

Reference

IPDFDeviceActionHandler Interface


IPDFDeviceActionHandler.HandleUriAction Method

IPDFDeviceActionHandlerHandleUriAction Method
Called for action that point to an Uri (Universal Resource Identifier)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
void HandleUriAction(
    IPDFDevice device,
    string uri
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
uri
Type: SystemString
See Also

Reference

IPDFDeviceActionHandler Interface


PDFAction Class

PDFAction Class
Represents the PDF action into a PDF document.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFAction

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFAction : IDisposable

The PDFAction type exposes the following members.

Constructors
 | Name | Description
Public method | PDFAction(PDFBookmark, IntPtr) | Initializes a new instance of the PDFAction class
Public method | PDFAction(PDFLink, IntPtr) | Initializes a new instance of the PDFAction class
Top
Properties
 | Name | Description
Public property | Document |
Public property | NativePointer |
Public property | Source |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFAction
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFAction and optionally releases the managed resources
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetActionType | Gets type of current action.
Public method | GetDest | Gets the PDFDest object associated with this action.
Public method | GetFilePath |
Public method | GetURIPath | Gets URL assigned to the current action.
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFAction Constructor

PDFAction Constructor
Overload List
 | Name | Description
Public method | PDFAction(PDFBookmark, IntPtr) | Initializes a new instance of the PDFAction class
Public method | PDFAction(PDFLink, IntPtr) | Initializes a new instance of the PDFAction class
Top
See Also

Reference

PDFAction Class


PDFAction Constructor (PDFBookmark, IntPtr)

PDFAction Constructor (PDFBookmark, IntPtr)
Initializes a new instance of the PDFAction class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFAction(
    PDFBookmark bookmark,
    IntPtr nativePointer
)

Parameters

bookmark
Type: Paroxe.PdfRendererPDFBookmark
nativePointer
Type: SystemIntPtr
See Also

Reference

PDFAction Class
PDFAction Overload


PDFAction Constructor (PDFLink, IntPtr)

PDFAction Constructor (PDFLink, IntPtr)
Initializes a new instance of the PDFAction class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFAction(
    PDFLink link,
    IntPtr nativePointer
)

Parameters

link
Type: Paroxe.PdfRendererPDFLink
nativePointer
Type: SystemIntPtr
See Also

Reference

PDFAction Class
PDFAction Overload


PDFAction Properties

PDFAction Properties

The PDFAction type exposes the following members.

Properties
 | Name | Description
Public property | Document |
Public property | NativePointer |
Public property | Source |
Top
See Also

Reference

PDFAction Class


PDFAction.Document Property

PDFActionDocument Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument Document { get; }

Property Value

Type: PDFDocument
See Also

Reference

PDFAction Class


PDFAction.NativePointer Property

PDFActionNativePointer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IntPtr NativePointer { get; }

Property Value

Type: IntPtr
See Also

Reference

PDFAction Class


PDFAction.Source Property

PDFActionSource Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IDisposable Source { get; }

Property Value

Type: IDisposable
See Also

Reference

PDFAction Class


PDFAction Methods

PDFAction Methods

The PDFAction type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetActionType | Gets type of current action.
Public method | GetDest | Gets the PDFDest object associated with this action.
Public method | GetFilePath |
Public method | GetURIPath | Gets URL assigned to the current action.
Top
See Also

Reference

PDFAction Class


PDFAction.Dispose Method

PDFActionDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFAction
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFAction and optionally releases the managed resources
Top
See Also

Reference

PDFAction Class


PDFAction.Dispose Method

PDFActionDispose Method
Releases all resources used by the PDFAction

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFAction Class
Dispose Overload


PDFAction.Dispose Method (Boolean)

PDFActionDispose Method (Boolean)
Releases the unmanaged resources used by the PDFAction and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFAction Class
Dispose Overload


PDFAction.Finalize Method

PDFActionFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFAction Class


PDFAction.GetActionType Method

PDFActionGetActionType Method
Gets type of current action.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFActionActionType GetActionType()

Return Value

Type: PDFActionActionType
See Also

Reference

PDFAction Class


PDFAction.GetDest Method

PDFActionGetDest Method
Gets the PDFDest object associated with this action.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDest GetDest()

Return Value

Type: PDFDest
See Also

Reference

PDFAction Class


PDFAction.GetFilePath Method

PDFActionGetFilePath Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string GetFilePath()

Return Value

Type: String
See Also

Reference

PDFAction Class


PDFAction.GetURIPath Method

PDFActionGetURIPath Method
Gets URL assigned to the current action.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string GetURIPath()

Return Value

Type: String
See Also

Reference

PDFAction Class


PDFAction.ActionType Enumeration

PDFActionActionType Enumeration

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public enum ActionType
Members
Member name | Value | Description
Unsupported | 0 | Unsupported action type.
GoTo | 1 | Go to a destination within current document.
RemoteGoTo | 2 | Go to a destination within another document.
Uri | 3 | Universal Resource Identifier, including web pages and other Internet based resources.
Launch | 4 | Launch an application or open a file.
Unknown | 133709999 |
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFActionHandlerHelper Class

PDFActionHandlerHelper Class
Provides default action handling implementation.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFActionHandlerHelper

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public static class PDFActionHandlerHelper

The PDFActionHandlerHelper type exposes the following members.

Methods
Name | Description
ExecuteAction |
ExecuteBookmarkAction |
ExecuteLinkAction |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFActionHandlerHelper Methods

PDFActionHandlerHelper Methods

The PDFActionHandlerHelper type exposes the following members.

Methods
Name | Description
ExecuteAction |
ExecuteBookmarkAction |
ExecuteLinkAction |
Top
See Also

Reference

PDFActionHandlerHelper Class


PDFActionHandlerHelper.ExecuteAction Method

PDFActionHandlerHelperExecuteAction Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public static void ExecuteAction(
    IPDFDeviceActionHandler actionHandler,
    IPDFDevice device,
    PDFAction action
)

Parameters

actionHandler
Type: Paroxe.PdfRendererIPDFDeviceActionHandler
device
Type: Paroxe.PdfRendererIPDFDevice
action
Type: Paroxe.PdfRendererPDFAction
See Also

Reference

PDFActionHandlerHelper Class


PDFActionHandlerHelper.ExecuteBookmarkAction Method

PDFActionHandlerHelperExecuteBookmarkAction Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public static void ExecuteBookmarkAction(
    IPDFDevice device,
    PDFBookmark bookmark
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
bookmark
Type: Paroxe.PdfRendererPDFBookmark
See Also

Reference

PDFActionHandlerHelper Class


PDFActionHandlerHelper.ExecuteLinkAction Method

PDFActionHandlerHelperExecuteLinkAction Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public static void ExecuteLinkAction(
    IPDFDevice device,
    PDFLink link
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
link
Type: Paroxe.PdfRendererPDFLink
See Also

Reference

PDFActionHandlerHelper Class


PDFAsset Class

PDFAsset Class
For internal use only.
Inheritance Hierarchy
SystemObject
Object
ScriptableObject
Paroxe.PdfRendererPDFAsset

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFAsset : ScriptableObject

The PDFAsset type exposes the following members.

Constructors
 | Name | Description
Public method | PDFAsset | Initializes a new instance of the PDFAsset class
Top
Properties
 | Name | Description
Public property | Password |
Top
Methods
 | Name | Description
Public method | Load |
Top
Fields
 | Name | Description
Public field | m_FileContent |
Public field | m_Password |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFAsset Constructor

PDFAsset Constructor
Initializes a new instance of the PDFAsset class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFAsset()
See Also

Reference

PDFAsset Class


PDFAsset Properties

PDFAsset Properties

The PDFAsset type exposes the following members.

Properties
 | Name | Description
Public property | Password |
Top
See Also

Reference

PDFAsset Class


PDFAsset.Password Property

PDFAssetPassword Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string Password { get; set; }

Property Value

Type: String
See Also

Reference

PDFAsset Class


PDFAsset Methods

PDFAsset Methods

The PDFAsset type exposes the following members.

Methods
 | Name | Description
Public method | Load |
Top
See Also

Reference

PDFAsset Class


PDFAsset.Load Method

PDFAssetLoad Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Load(
    byte[] fileContent
)

Parameters

fileContent
Type: SystemByte
See Also

Reference

PDFAsset Class


PDFAsset Fields

PDFAsset Fields

The PDFAsset type exposes the following members.

Fields
 | Name | Description
Public field | m_FileContent |
Public field | m_Password |
Top
See Also

Reference

PDFAsset Class


PDFAsset.m_FileContent Field

PDFAssetm_FileContent Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public byte[] m_FileContent

Field Value

Type: Byte
See Also

Reference

PDFAsset Class


PDFAsset.m_Password Field

PDFAssetm_Password Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string m_Password

Field Value

Type: String
See Also

Reference

PDFAsset Class


PDFBookmark Class

PDFBookmark Class
Represents the bookmark into a PDF document.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFBookmark

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFBookmark : IDisposable

The PDFBookmark type exposes the following members.

Constructors
 | Name | Description
Public method | PDFBookmark(PDFDocument, PDFBookmark, IntPtr) | Initializes a new instance of the PDFBookmark class
Public method | PDFBookmark(PDFDocument, PDFBookmark, IntPtr, IPDFDevice) | Initializes a new instance of the PDFBookmark class
Top
Properties
 | Name | Description
Public property | ChildCount |
Public property | Document |
Public property | IsTopLevelBookmark |
Public property | NativePointer |
Public property | Parent |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFBookmark
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFBookmark and optionally releases the managed resources
Public method | EnumerateChildrenBookmarks |
Public method | ExecuteBookmarkAction |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetAction |
Public method | GetChild |
Public method | GetChildrenBookmarks |
Public method | GetDest |
Public method | GetFirstChild |
Public method | GetNextSibling |
Public method | GetTitle |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFBookmark Constructor

PDFBookmark Constructor
Overload List
 | Name | Description
Public method | PDFBookmark(PDFDocument, PDFBookmark, IntPtr) | Initializes a new instance of the PDFBookmark class
Public method | PDFBookmark(PDFDocument, PDFBookmark, IntPtr, IPDFDevice) | Initializes a new instance of the PDFBookmark class
Top
See Also

Reference

PDFBookmark Class


PDFBookmark Constructor (PDFDocument, PDFBookmark, IntPtr)

PDFBookmark Constructor (PDFDocument, PDFBookmark, IntPtr)
Initializes a new instance of the PDFBookmark class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFBookmark(
    PDFDocument document,
    PDFBookmark parentBookmark,
    IntPtr nativePointer
)

Parameters

document
Type: Paroxe.PdfRendererPDFDocument
parentBookmark
Type: Paroxe.PdfRendererPDFBookmark
nativePointer
Type: SystemIntPtr
See Also

Reference

PDFBookmark Class
PDFBookmark Overload


PDFBookmark Constructor (PDFDocument, PDFBookmark, IntPtr, IPDFDevice)

PDFBookmark Constructor (PDFDocument, PDFBookmark, IntPtr, IPDFDevice)
Initializes a new instance of the PDFBookmark class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFBookmark(
    PDFDocument document,
    PDFBookmark parentBookmark,
    IntPtr nativePointer,
    IPDFDevice device
)

Parameters

document
Type: Paroxe.PdfRendererPDFDocument
parentBookmark
Type: Paroxe.PdfRendererPDFBookmark
nativePointer
Type: SystemIntPtr
device
Type: Paroxe.PdfRendererIPDFDevice
See Also

Reference

PDFBookmark Class
PDFBookmark Overload


PDFBookmark Properties

PDFBookmark Properties

The PDFBookmark type exposes the following members.

Properties
 | Name | Description
Public property | ChildCount |
Public property | Document |
Public property | IsTopLevelBookmark |
Public property | NativePointer |
Public property | Parent |
Top
See Also

Reference

PDFBookmark Class


PDFBookmark.ChildCount Property

PDFBookmarkChildCount Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int ChildCount { get; }

Property Value

Type: Int32
See Also

Reference

PDFBookmark Class


PDFBookmark.Document Property

PDFBookmarkDocument Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument Document { get; }

Property Value

Type: PDFDocument
See Also

Reference

PDFBookmark Class


PDFBookmark.IsTopLevelBookmark Property

PDFBookmarkIsTopLevelBookmark Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool IsTopLevelBookmark { get; }

Property Value

Type: Boolean
See Also

Reference

PDFBookmark Class


PDFBookmark.NativePointer Property

PDFBookmarkNativePointer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IntPtr NativePointer { get; }

Property Value

Type: IntPtr
See Also

Reference

PDFBookmark Class


PDFBookmark.Parent Property

PDFBookmarkParent Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFBookmark Parent { get; }

Property Value

Type: PDFBookmark
See Also

Reference

PDFBookmark Class


PDFBookmark Methods

PDFBookmark Methods

The PDFBookmark type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | EnumerateChildrenBookmarks |
Public method | ExecuteBookmarkAction |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetAction |
Public method | GetChild |
Public method | GetChildrenBookmarks |
Public method | GetDest |
Public method | GetFirstChild |
Public method | GetNextSibling |
Public method | GetTitle |
Top
See Also

Reference

PDFBookmark Class


PDFBookmark.Dispose Method

PDFBookmarkDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFBookmark
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFBookmark and optionally releases the managed resources
Top
See Also

Reference

PDFBookmark Class


PDFBookmark.Dispose Method

PDFBookmarkDispose Method
Releases all resources used by the PDFBookmark

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFBookmark Class
Dispose Overload


PDFBookmark.Dispose Method (Boolean)

PDFBookmarkDispose Method (Boolean)
Releases the unmanaged resources used by the PDFBookmark and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFBookmark Class
Dispose Overload


PDFBookmark.EnumerateChildrenBookmarks Method

PDFBookmarkEnumerateChildrenBookmarks Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IEnumerable<PDFBookmark> EnumerateChildrenBookmarks()

Return Value

Type: IEnumerable PDFBookmark
See Also

Reference

PDFBookmark Class


PDFBookmark.ExecuteBookmarkAction Method

PDFBookmarkExecuteBookmarkAction Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void ExecuteBookmarkAction()
See Also

Reference

PDFBookmark Class


PDFBookmark.Finalize Method

PDFBookmarkFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFBookmark Class


PDFBookmark.GetAction Method

PDFBookmarkGetAction Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFAction GetAction()

Return Value

Type: PDFAction
See Also

Reference

PDFBookmark Class


PDFBookmark.GetChild Method

PDFBookmarkGetChild Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFBookmark GetChild(
    int index
)

Parameters

index
Type: SystemInt32

Return Value

Type: PDFBookmark
See Also

Reference

PDFBookmark Class


PDFBookmark.GetChildrenBookmarks Method

PDFBookmarkGetChildrenBookmarks Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IList<PDFBookmark> GetChildrenBookmarks()

Return Value

Type: IList PDFBookmark
See Also

Reference

PDFBookmark Class


PDFBookmark.GetDest Method

PDFBookmarkGetDest Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDest GetDest()

Return Value

Type: PDFDest
See Also

Reference

PDFBookmark Class


PDFBookmark.GetFirstChild Method

PDFBookmarkGetFirstChild Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFBookmark GetFirstChild()

Return Value

Type: PDFBookmark
See Also

Reference

PDFBookmark Class


PDFBookmark.GetNextSibling Method

PDFBookmarkGetNextSibling Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFBookmark GetNextSibling()

Return Value

Type: PDFBookmark
See Also

Reference

PDFBookmark Class


PDFBookmark.GetTitle Method

PDFBookmarkGetTitle Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string GetTitle()

Return Value

Type: String
See Also

Reference

PDFBookmark Class


PDFColoredRect Structure

PDFColoredRect Structure
Represent a colored rect within a page. This class is used mainly for search results highlightment. Will maybe used for text selection in the future.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public struct PDFColoredRect

The PDFColoredRect type exposes the following members.

Constructors
 | Name | Description
Public method | PDFColoredRect | Initializes a new instance of the PDFColoredRect class
Top
Fields
 | Name | Description
Public field | color |
Public field | pageRect |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFColoredRect Constructor

PDFColoredRect Constructor
Initializes a new instance of the PDFColoredRect class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFColoredRect(
    Rect pageRect,
    Color color
)

Parameters

pageRect
Type: Rect
color
Type: Color
See Also

Reference

PDFColoredRect Structure


PDFColoredRect Fields

PDFColoredRect Fields

The PDFColoredRect type exposes the following members.

Fields
 | Name | Description
Public field | color |
Public field | pageRect |
Top
See Also

Reference

PDFColoredRect Structure


PDFColoredRect.color Field

PDFColoredRectcolor Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Color color

Field Value

Type: Color
See Also

Reference

PDFColoredRect Structure


PDFColoredRect.pageRect Field

PDFColoredRectpageRect Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Rect pageRect

Field Value

Type: Rect
See Also

Reference

PDFColoredRect Structure


PDFDest Class

PDFDest Class
Represents a destination into a PDF document.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFDest

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFDest : IDisposable

The PDFDest type exposes the following members.

Constructors
 | Name | Description
Public method | PDFDest(PDFAction, IntPtr) | Initializes a new instance of the PDFDest class
Public method | PDFDest(PDFBookmark, IntPtr) | Initializes a new instance of the PDFDest class
Public method | PDFDest(PDFLink, IntPtr) | Initializes a new instance of the PDFDest class
Top
Properties
 | Name | Description
Public property | Document |
Public property | NativePointer |
Public property | PageIndex |
Public property | Source |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFDest
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFDest and optionally releases the managed resources
Protected method | Finalize | (Overrides ObjectFinalize.)
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFDest Constructor

PDFDest Constructor
Overload List
 | Name | Description
Public method | PDFDest(PDFAction, IntPtr) | Initializes a new instance of the PDFDest class
Public method | PDFDest(PDFBookmark, IntPtr) | Initializes a new instance of the PDFDest class
Public method | PDFDest(PDFLink, IntPtr) | Initializes a new instance of the PDFDest class
Top
See Also

Reference

PDFDest Class


PDFDest Constructor (PDFAction, IntPtr)

PDFDest Constructor (PDFAction, IntPtr)
Initializes a new instance of the PDFDest class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDest(
    PDFAction action,
    IntPtr nativePointer
)

Parameters

action
Type: Paroxe.PdfRendererPDFAction
nativePointer
Type: SystemIntPtr
See Also

Reference

PDFDest Class
PDFDest Overload


PDFDest Constructor (PDFBookmark, IntPtr)

PDFDest Constructor (PDFBookmark, IntPtr)
Initializes a new instance of the PDFDest class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDest(
    PDFBookmark bookmark,
    IntPtr nativePointer
)

Parameters

bookmark
Type: Paroxe.PdfRendererPDFBookmark
nativePointer
Type: SystemIntPtr
See Also

Reference

PDFDest Class
PDFDest Overload


PDFDest Constructor (PDFLink, IntPtr)

PDFDest Constructor (PDFLink, IntPtr)
Initializes a new instance of the PDFDest class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDest(
    PDFLink link,
    IntPtr nativePointer
)

Parameters

link
Type: Paroxe.PdfRendererPDFLink
nativePointer
Type: SystemIntPtr
See Also

Reference

PDFDest Class
PDFDest Overload


PDFDest Properties

PDFDest Properties

The PDFDest type exposes the following members.

Properties
 | Name | Description
Public property | Document |
Public property | NativePointer |
Public property | PageIndex |
Public property | Source |
Top
See Also

Reference

PDFDest Class


PDFDest.Document Property

PDFDestDocument Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument Document { get; }

Property Value

Type: PDFDocument
See Also

Reference

PDFDest Class


PDFDest.NativePointer Property

PDFDestNativePointer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IntPtr NativePointer { get; }

Property Value

Type: IntPtr
See Also

Reference

PDFDest Class


PDFDest.PageIndex Property

PDFDestPageIndex Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int PageIndex { get; }

Property Value

Type: Int32
See Also

Reference

PDFDest Class


PDFDest.Source Property

PDFDestSource Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IDisposable Source { get; }

Property Value

Type: IDisposable
See Also

Reference

PDFDest Class


PDFDest Methods

PDFDest Methods

The PDFDest type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | Finalize | (Overrides ObjectFinalize.)
Top
See Also

Reference

PDFDest Class


PDFDest.Dispose Method

PDFDestDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFDest
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFDest and optionally releases the managed resources
Top
See Also

Reference

PDFDest Class


PDFDest.Dispose Method

PDFDestDispose Method
Releases all resources used by the PDFDest

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFDest Class
Dispose Overload


PDFDest.Dispose Method (Boolean)

PDFDestDispose Method (Boolean)
Releases the unmanaged resources used by the PDFDest and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFDest Class
Dispose Overload


PDFDest.Finalize Method

PDFDestFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFDest Class


PDFDocument Class

PDFDocument Class
Represents a PDF document. This class is the entry point of all functionalities.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFDocument

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFDocument : IDisposable

The PDFDocument type exposes the following members.

Constructors
 | Name | Description
Public method | PDFDocument(Byte) | Open PDF Document with the specified byte array.
Public method | PDFDocument(String) | Open PDF Document located at the specified path
Public method | PDFDocument(Byte, String) | Open PDF Document with the specified byte array.
Public method | PDFDocument(String, String) | Initializes a new instance of the PDFDocument class
Top
Properties
 | Name | Description
Public property | DocumentBuffer | The byte array of the document.
Public property | IsValid | Return if the document is valid. The document can be invalid if the password is invalid or if the document itseft is corrupted. See PDFLibrary.GetLastError.
Public property | NativePointer |
Public property | Renderer | Return a convenience PDFRenderer instance.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFDocument
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFDocument and optionally releases the managed resources
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetPage |
Public method | GetPageCount |
Public method | GetPageHeight |
Public method | GetPageSize |
Public method | GetPageWidth |
Public method | GetRootBookmark | Return the root bookmark of the document.
Public method | GetRootBookmark(IPDFDevice) | Return the root bookmark of the document.
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFDocument Constructor

PDFDocument Constructor
Overload List
 | Name | Description
Public method | PDFDocument(Byte) | Open PDF Document with the specified byte array.
Public method | PDFDocument(String) | Open PDF Document located at the specified path
Public method | PDFDocument(Byte, String) | Open PDF Document with the specified byte array.
Public method | PDFDocument(String, String) | Initializes a new instance of the PDFDocument class
Top
See Also

Reference

PDFDocument Class


PDFDocument Constructor (Byte[])

PDFDocument Constructor (Byte)
Open PDF Document with the specified byte array.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument(
    byte[] buffer
)

Parameters

buffer
Type: SystemByte
See Also

Reference

PDFDocument Class
PDFDocument Overload


PDFDocument Constructor (String)

PDFDocument Constructor (String)
Open PDF Document located at the specified path

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument(
    string filePath
)

Parameters

filePath
Type: SystemString
See Also

Reference

PDFDocument Class
PDFDocument Overload


PDFDocument Constructor (Byte[], String)

PDFDocument Constructor (Byte, String)
Open PDF Document with the specified byte array.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument(
    byte[] buffer,
    string password
)

Parameters

buffer
Type: SystemByte
password
Type: SystemString
Can be null or empty
See Also

Reference

PDFDocument Class
PDFDocument Overload


PDFDocument Constructor (String, String)

PDFDocument Constructor (String, String)
Initializes a new instance of the PDFDocument class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument(
    string filePath,
    string password
)

Parameters

filePath
Type: SystemString
password
Type: SystemString
Can be null or empty
See Also

Reference

PDFDocument Class
PDFDocument Overload


PDFDocument Properties

PDFDocument Properties

The PDFDocument type exposes the following members.

Properties
 | Name | Description
Public property | DocumentBuffer | The byte array of the document.
Public property | IsValid | Return if the document is valid. The document can be invalid if the password is invalid or if the document itseft is corrupted. See PDFLibrary.GetLastError.
Public property | NativePointer |
Public property | Renderer | Return a convenience PDFRenderer instance.
Top
See Also

Reference

PDFDocument Class


PDFDocument.DocumentBuffer Property

PDFDocumentDocumentBuffer Property
The byte array of the document.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public byte[] DocumentBuffer { get; }

Property Value

Type: Byte
See Also

Reference

PDFDocument Class


PDFDocument.IsValid Property

PDFDocumentIsValid Property
Return if the document is valid. The document can be invalid if the password is invalid or if the document itseft is corrupted. See PDFLibrary.GetLastError.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool IsValid { get; }

Property Value

Type: Boolean
See Also

Reference

PDFDocument Class


PDFDocument.NativePointer Property

PDFDocumentNativePointer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IntPtr NativePointer { get; }

Property Value

Type: IntPtr
See Also

Reference

PDFDocument Class


PDFDocument.Renderer Property

PDFDocumentRenderer Property
Return a convenience PDFRenderer instance.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFRenderer Renderer { get; }

Property Value

Type: PDFRenderer
See Also

Reference

PDFDocument Class


PDFDocument Methods

PDFDocument Methods

The PDFDocument type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetPage |
Public method | GetPageCount |
Public method | GetPageHeight |
Public method | GetPageSize |
Public method | GetPageWidth |
Public method | GetRootBookmark | Return the root bookmark of the document.
Public method | GetRootBookmark(IPDFDevice) | Return the root bookmark of the document.
Top
See Also

Reference

PDFDocument Class


PDFDocument.Dispose Method

PDFDocumentDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFDocument
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFDocument and optionally releases the managed resources
Top
See Also

Reference

PDFDocument Class


PDFDocument.Dispose Method

PDFDocumentDispose Method
Releases all resources used by the PDFDocument

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFDocument Class
Dispose Overload


PDFDocument.Dispose Method (Boolean)

PDFDocumentDispose Method (Boolean)
Releases the unmanaged resources used by the PDFDocument and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFDocument Class
Dispose Overload


PDFDocument.Finalize Method

PDFDocumentFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFDocument Class


PDFDocument.GetPage Method

PDFDocumentGetPage Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFPage GetPage(
    int index
)

Parameters

index
Type: SystemInt32

Return Value

Type: PDFPage
See Also

Reference

PDFDocument Class


PDFDocument.GetPageCount Method

PDFDocumentGetPageCount Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int GetPageCount()

Return Value

Type: Int32
See Also

Reference

PDFDocument Class


PDFDocument.GetPageHeight Method

PDFDocumentGetPageHeight Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int GetPageHeight(
    int pageIndex
)

Parameters

pageIndex
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

PDFDocument Class


PDFDocument.GetPageSize Method

PDFDocumentGetPageSize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Vector2 GetPageSize(
    int pageIndex
)

Parameters

pageIndex
Type: SystemInt32

Return Value

Type: Vector2
See Also

Reference

PDFDocument Class


PDFDocument.GetPageWidth Method

PDFDocumentGetPageWidth Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int GetPageWidth(
    int pageIndex
)

Parameters

pageIndex
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

PDFDocument Class


PDFDocument.GetRootBookmark Method

PDFDocumentGetRootBookmark Method
Overload List
 | Name | Description
Public method | GetRootBookmark | Return the root bookmark of the document.
Public method | GetRootBookmark(IPDFDevice) | Return the root bookmark of the document.
Top
See Also

Reference

PDFDocument Class


PDFDocument.GetRootBookmark Method

PDFDocumentGetRootBookmark Method
Return the root bookmark of the document.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFBookmark GetRootBookmark()

Return Value

Type: PDFBookmark
See Also

Reference

PDFDocument Class
GetRootBookmark Overload


PDFDocument.GetRootBookmark Method (IPDFDevice)

PDFDocumentGetRootBookmark Method (IPDFDevice)
Return the root bookmark of the document.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFBookmark GetRootBookmark(
    IPDFDevice device
)

Parameters

device
Type: Paroxe.PdfRendererIPDFDevice
Pass the device that will receive bookmarks action

Return Value

Type: PDFBookmark
See Also

Reference

PDFDocument Class
GetRootBookmark Overload


PDFLibrary Class

PDFLibrary Class
Contains GetLastError() function
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFLibrary

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFLibrary : IDisposable

The PDFLibrary type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFLibrary
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFLibrary and optionally releases the managed resources
Protected method | Finalize | (Overrides ObjectFinalize.)
 | GetLastError | Return the last error code.
Top
Fields
Name | Description
CurrentVersion |
PLUGIN_ASSEMBLY |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFLibrary Methods

PDFLibrary Methods

The PDFLibrary type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | Finalize | (Overrides ObjectFinalize.)
 | GetLastError | Return the last error code.
Top
See Also

Reference

PDFLibrary Class


PDFLibrary.Dispose Method

PDFLibraryDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFLibrary
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFLibrary and optionally releases the managed resources
Top
See Also

Reference

PDFLibrary Class


PDFLibrary.Dispose Method

PDFLibraryDispose Method
Releases all resources used by the PDFLibrary

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFLibrary Class
Dispose Overload


PDFLibrary.Dispose Method (Boolean)

PDFLibraryDispose Method (Boolean)
Releases the unmanaged resources used by the PDFLibrary and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFLibrary Class
Dispose Overload


PDFLibrary.Finalize Method

PDFLibraryFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFLibrary Class


PDFLibrary.GetLastError Method

PDFLibraryGetLastError Method
Return the last error code.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public static PDFLibraryErrorCode GetLastError()

Return Value

Type: PDFLibraryErrorCode
See Also

Reference

PDFLibrary Class


PDFLibrary Fields

PDFLibrary Fields

The PDFLibrary type exposes the following members.

Fields
Name | Description
CurrentVersion |
PLUGIN_ASSEMBLY |
Top
See Also

Reference

PDFLibrary Class


PDFLibrary.CurrentVersion Field

PDFLibraryCurrentVersion Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public const string CurrentVersion = "3.0"

Field Value

Type: String
See Also

Reference

PDFLibrary Class


PDFLibrary.PLUGIN_ASSEMBLY Field

PDFLibraryPLUGIN_ASSEMBLY Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public const string PLUGIN_ASSEMBLY = "pdfrenderer"

Field Value

Type: String
See Also

Reference

PDFLibrary Class


PDFLibrary.ErrorCode Enumeration

PDFLibraryErrorCode Enumeration

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public enum ErrorCode
Members
Member name | Value | Description
ErrSuccess | 0 |
ErrUnknown | 1 |
ErrFile | 2 |
ErrFormat | 3 |
ErrPassword | 4 |
ErrSecurity | 5 |
ErrPage | 6 |
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFLink Class

PDFLink Class
Represents the annotation link in a PDF page.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFLink

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFLink : IDisposable

The PDFLink type exposes the following members.

Constructors
 | Name | Description
Public method | PDFLink | Initializes a new instance of the PDFLink class
Top
Properties
 | Name | Description
Public property | NativePointer |
Public property | Page |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFLink
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFLink and optionally releases the managed resources
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetAction | Gets the PDF action assigned to a link.
Public method | GetDest | Gets the named destination assigned to a link. Return null if there is no destination associated with the link, in this case the application should try GetAction() instead.
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFLink Constructor

PDFLink Constructor
Initializes a new instance of the PDFLink class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFLink(
    PDFPage page,
    IntPtr nativePointer
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
nativePointer
Type: SystemIntPtr
See Also

Reference

PDFLink Class


PDFLink Properties

PDFLink Properties

The PDFLink type exposes the following members.

Properties
 | Name | Description
Public property | NativePointer |
Public property | Page |
Top
See Also

Reference

PDFLink Class


PDFLink.NativePointer Property

PDFLinkNativePointer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IntPtr NativePointer { get; }

Property Value

Type: IntPtr
See Also

Reference

PDFLink Class


PDFLink.Page Property

PDFLinkPage Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFPage Page { get; }

Property Value

Type: PDFPage
See Also

Reference

PDFLink Class


PDFLink Methods

PDFLink Methods

The PDFLink type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetAction | Gets the PDF action assigned to a link.
Public method | GetDest | Gets the named destination assigned to a link. Return null if there is no destination associated with the link, in this case the application should try GetAction() instead.
Top
See Also

Reference

PDFLink Class


PDFLink.Dispose Method

PDFLinkDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFLink
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFLink and optionally releases the managed resources
Top
See Also

Reference

PDFLink Class


PDFLink.Dispose Method

PDFLinkDispose Method
Releases all resources used by the PDFLink

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFLink Class
Dispose Overload


PDFLink.Dispose Method (Boolean)

PDFLinkDispose Method (Boolean)
Releases the unmanaged resources used by the PDFLink and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFLink Class
Dispose Overload


PDFLink.Finalize Method

PDFLinkFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFLink Class


PDFLink.GetAction Method

PDFLinkGetAction Method
Gets the PDF action assigned to a link.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFAction GetAction()

Return Value

Type: PDFAction
See Also

Reference

PDFLink Class


PDFLink.GetDest Method

PDFLinkGetDest Method
Gets the named destination assigned to a link. Return null if there is no destination associated with the link, in this case the application should try GetAction() instead.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDest GetDest()

Return Value

Type: PDFDest
See Also

Reference

PDFLink Class


PDFPage Class

PDFPage Class
Represents a PDF page inside document.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFPage

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFPage : IDisposable, IEquatable<PDFPage>

The PDFPage type exposes the following members.

Constructors
 | Name | Description
Public method | PDFPage | Initializes a new instance of the PDFPage class
Top
Properties
 | Name | Description
Public property | Document |
Public property | NativePointer |
Public property | PageIndex |
Top
Methods
 | Name | Description
Public method | ConvertPagePositionToUnityUIDevicePosition |
Public method | ConvertPageRectToDeviceRect |
Public method | ConvertUnityUIDevicePositionToPagePosition |
Public method | DeviceToPage |
Public method | Dispose | Releases all resources used by the PDFPage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFPage and optionally releases the managed resources
Public method | Equals |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetLinkAtPoint(Vector2) |
Public method | GetLinkAtPoint(Double, Double) |
Public method | GetPageSize |
Public method | GetTextPage | Return an instance of PDFTextPage that give access the the current page text content
Public method | PageToDevice |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFPage Constructor

PDFPage Constructor
Initializes a new instance of the PDFPage class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFPage(
    PDFDocument document,
    int pageIndex
)

Parameters

document
Type: Paroxe.PdfRendererPDFDocument
pageIndex
Type: SystemInt32
See Also

Reference

PDFPage Class


PDFPage Properties

PDFPage Properties

The PDFPage type exposes the following members.

Properties
 | Name | Description
Public property | Document |
Public property | NativePointer |
Public property | PageIndex |
Top
See Also

Reference

PDFPage Class


PDFPage.Document Property

PDFPageDocument Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument Document { get; }

Property Value

Type: PDFDocument
See Also

Reference

PDFPage Class


PDFPage.NativePointer Property

PDFPageNativePointer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IntPtr NativePointer { get; }

Property Value

Type: IntPtr
See Also

Reference

PDFPage Class


PDFPage.PageIndex Property

PDFPagePageIndex Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int PageIndex { get; }

Property Value

Type: Int32
See Also

Reference

PDFPage Class


PDFPage Methods

PDFPage Methods

The PDFPage type exposes the following members.

Methods
 | Name | Description
Public method | ConvertPagePositionToUnityUIDevicePosition |
Public method | ConvertPageRectToDeviceRect |
Public method | ConvertUnityUIDevicePositionToPagePosition |
Public method | DeviceToPage |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetLinkAtPoint(Vector2) |
Public method | GetLinkAtPoint(Double, Double) |
Public method | GetPageSize |
Public method | GetTextPage | Return an instance of PDFTextPage that give access the the current page text content
Public method | PageToDevice |
Top
See Also

Reference

PDFPage Class


PDFPage.ConvertPagePositionToUnityUIDevicePosition Method

PDFPageConvertPagePositionToUnityUIDevicePosition Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Vector2 ConvertPagePositionToUnityUIDevicePosition(
    Vector2 pagePoint,
    Vector2 devicePageSize
)

Parameters

pagePoint
Type: Vector2
devicePageSize
Type: Vector2

Return Value

Type: Vector2
See Also

Reference

PDFPage Class


PDFPage.ConvertPageRectToDeviceRect Method

PDFPageConvertPageRectToDeviceRect Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Rect ConvertPageRectToDeviceRect(
    Rect pageRect,
    Vector2 devicePageSize
)

Parameters

pageRect
Type: Rect
devicePageSize
Type: Vector2

Return Value

Type: Rect
See Also

Reference

PDFPage Class


PDFPage.ConvertUnityUIDevicePositionToPagePosition Method

PDFPageConvertUnityUIDevicePositionToPagePosition Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Vector2 ConvertUnityUIDevicePositionToPagePosition(
    Vector2 devicePoint,
    Vector2 devicePageSize
)

Parameters

devicePoint
Type: Vector2
devicePageSize
Type: Vector2

Return Value

Type: Vector2
See Also

Reference

PDFPage Class


PDFPage.DeviceToPage Method

PDFPageDeviceToPage Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Vector2 DeviceToPage(
    int startX,
    int startY,
    int sizeX,
    int sizeY,
    PDFPagePageRotation rotation,
    int deviceX,
    int deviceY
)

Parameters

startX
Type: SystemInt32
startY
Type: SystemInt32
sizeX
Type: SystemInt32
sizeY
Type: SystemInt32
rotation
Type: Paroxe.PdfRendererPDFPagePageRotation
deviceX
Type: SystemInt32
deviceY
Type: SystemInt32

Return Value

Type: Vector2
See Also

Reference

PDFPage Class


PDFPage.Dispose Method

PDFPageDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFPage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFPage and optionally releases the managed resources
Top
See Also

Reference

PDFPage Class


PDFPage.Dispose Method

PDFPageDispose Method
Releases all resources used by the PDFPage

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFPage Class
Dispose Overload


PDFPage.Dispose Method (Boolean)

PDFPageDispose Method (Boolean)
Releases the unmanaged resources used by the PDFPage and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFPage Class
Dispose Overload


PDFPage.Equals Method

PDFPageEquals Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool Equals(
    PDFPage other
)

Parameters

other
Type: Paroxe.PdfRendererPDFPage

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

PDFPage Class


PDFPage.Finalize Method

PDFPageFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFPage Class


PDFPage.GetLinkAtPoint Method

PDFPageGetLinkAtPoint Method
Overload List
 | Name | Description
Public method | GetLinkAtPoint(Vector2) |
Public method | GetLinkAtPoint(Double, Double) |
Top
See Also

Reference

PDFPage Class


PDFPage.GetLinkAtPoint Method (Vector2)

PDFPageGetLinkAtPoint Method (Vector2)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFLink GetLinkAtPoint(
    Vector2 pagePoint
)

Parameters

pagePoint
Type: Vector2

Return Value

Type: PDFLink
See Also

Reference

PDFPage Class
GetLinkAtPoint Overload


PDFPage.GetLinkAtPoint Method (Double, Double)

PDFPageGetLinkAtPoint Method (Double, Double)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFLink GetLinkAtPoint(
    double pageX,
    double pageY
)

Parameters

pageX
Type: SystemDouble
pageY
Type: SystemDouble

Return Value

Type: PDFLink
See Also

Reference

PDFPage Class
GetLinkAtPoint Overload


PDFPage.GetPageSize Method

PDFPageGetPageSize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Vector2 GetPageSize()

Return Value

Type: Vector2
See Also

Reference

PDFPage Class


PDFPage.GetTextPage Method

PDFPageGetTextPage Method
Return an instance of PDFTextPage that give access the the current page text content

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFTextPage GetTextPage()

Return Value

Type: PDFTextPage
See Also

Reference

PDFPage Class


PDFPage.PageToDevice Method

PDFPagePageToDevice Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Vector2 PageToDevice(
    int startX,
    int startY,
    int sizeX,
    int sizeY,
    PDFPagePageRotation rotation,
    int pageX,
    int pageY
)

Parameters

startX
Type: SystemInt32
startY
Type: SystemInt32
sizeX
Type: SystemInt32
sizeY
Type: SystemInt32
rotation
Type: Paroxe.PdfRendererPDFPagePageRotation
pageX
Type: SystemInt32
pageY
Type: SystemInt32

Return Value

Type: Vector2
See Also

Reference

PDFPage Class


PDFPage.PageRotation Enumeration

PDFPagePageRotation Enumeration
Rotations are clockwise

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public enum PageRotation
Members
Member name | Value | Description
Normal | 0 |
Rotate90 | 1 |
Rotate180 | 2 |
Rotate270 | 3 |
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFProgressiveSearch Class

PDFProgressiveSearch Class
Don't instantiate this class directly. Use the static method instead PDFProgressiveSearch.CreateSearch
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
UIBehaviour
Paroxe.PdfRendererPDFProgressiveSearch

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFProgressiveSearch : UIBehaviour

The PDFProgressiveSearch type exposes the following members.

Constructors
 | Name | Description
Public method | PDFProgressiveSearch | Initializes a new instance of the PDFProgressiveSearch class
Top
Methods
 | Name | Description
Public method | Abort | Stop the current search request.
 | CreateSearch | Create a progressive search object within the scene.
Public method | StartSearch | Start a new search and if a search is already started this method will stop it.
Top
Events
 | Name | Description
Public event | OnProgressChanged |
Public event | OnSearchFinished |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFProgressiveSearch Constructor

PDFProgressiveSearch Constructor
Initializes a new instance of the PDFProgressiveSearch class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFProgressiveSearch()
See Also

Reference

PDFProgressiveSearch Class


PDFProgressiveSearch Methods

PDFProgressiveSearch Methods

The PDFProgressiveSearch type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Stop the current search request.
 | CreateSearch | Create a progressive search object within the scene.
Public method | StartSearch | Start a new search and if a search is already started this method will stop it.
Top
See Also

Reference

PDFProgressiveSearch Class


PDFProgressiveSearch.Abort Method

PDFProgressiveSearchAbort Method
Stop the current search request.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Abort()
See Also

Reference

PDFProgressiveSearch Class


PDFProgressiveSearch.CreateSearch Method

PDFProgressiveSearchCreateSearch Method
Create a progressive search object within the scene.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public static PDFProgressiveSearch CreateSearch(
    PDFDocument document,
    float timeBudget
)

Parameters

document
Type: Paroxe.PdfRendererPDFDocument
timeBudget
Type: SystemSingle
Time budget per frame. The value must be metween 0.0f and 1.0f

Return Value

Type: PDFProgressiveSearch
See Also

Reference

PDFProgressiveSearch Class


PDFProgressiveSearch.StartSearch Method

PDFProgressiveSearchStartSearch Method
Start a new search and if a search is already started this method will stop it.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void StartSearch(
    string search,
    PDFSearchHandleMatchOption flags
)

Parameters

search
Type: SystemString
flags
Type: Paroxe.PdfRendererPDFSearchHandleMatchOption
PDFSearchHandle.MATCH_CASE, (PDFSearchHandle.MATCH_WHOLE_WORD or PDFSearchHandle.MATCH_CASE | PDFSearchHandle.MATCH_WHOLE_WORD)
See Also

Reference

PDFProgressiveSearch Class


PDFProgressiveSearch Events

PDFProgressiveSearch Events

The PDFProgressiveSearch type exposes the following members.

Events
 | Name | Description
Public event | OnProgressChanged |
Public event | OnSearchFinished |
Top
See Also

Reference

PDFProgressiveSearch Class


PDFProgressiveSearch.OnProgressChanged Event

PDFProgressiveSearchOnProgressChanged Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFProgressiveSearchProgressEventHandler OnProgressChanged

Value

Type: Paroxe.PdfRendererPDFProgressiveSearchProgressEventHandler
See Also

Reference

PDFProgressiveSearch Class


PDFProgressiveSearch.OnSearchFinished Event

PDFProgressiveSearchOnSearchFinished Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFProgressiveSearchSearchFinishedEventHandler OnSearchFinished

Value

Type: Paroxe.PdfRendererPDFProgressiveSearchSearchFinishedEventHandler
See Also

Reference

PDFProgressiveSearch Class


PDFProgressiveSearch.ProgressEventHandler Delegate

PDFProgressiveSearchProgressEventHandler Delegate

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public delegate void ProgressEventHandler(
    PDFProgressiveSearch sender,
    int total
)

Parameters

sender
Type: Paroxe.PdfRendererPDFProgressiveSearch
total
Type: SystemInt32
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFProgressiveSearch.SearchFinishedEventHandler Delegate

PDFProgressiveSearchSearchFinishedEventHandler Delegate

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public delegate void SearchFinishedEventHandler(
    PDFProgressiveSearch sender,
    IList<PDFSearchResult>[] searchResults
)

Parameters

sender
Type: Paroxe.PdfRendererPDFProgressiveSearch
searchResults
Type: System.Collections.GenericIList PDFSearchResult
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFRenderer Class

PDFRenderer Class
This class allow the application to render pages into textures.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFRenderer

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFRenderer : IDisposable

The PDFRenderer type exposes the following members.

Constructors
 | Name | Description
Public method | PDFRenderer | Initializes a new instance of the PDFRenderer class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFRenderer
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFRenderer and optionally releases the managed resources
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | RenderPageToByteArray(PDFPage) | Render page into a new byte array.
Public method | RenderPageToByteArray(PDFPage, Int32, Int32) | Render page into a new byte array.
Public method | RenderPageToByteArray(PDFPage, Int32, Int32, IPDFColoredRectListProvider) | Render page into a new byte array.
Public method | RenderPageToByteArray(PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRendererRenderSettings) | Render page into a new byte array.
Public method | RenderPageToExistingTexture(PDFPage, Texture2D) | Render page into an existing Texture2D.
Public method | RenderPageToExistingTexture(PDFPage, Texture2D, IPDFColoredRectListProvider) | Render page into an existing Texture2D.
Public method | RenderPageToExistingTexture(PDFPage, Texture2D, IPDFColoredRectListProvider, PDFRendererRenderSettings) | Render page into an existing Texture2D.
Public method | RenderPageToTexture(PDFPage) | Render page into a new Texture2D.
Public method | RenderPageToTexture(PDFPage, Int32, Int32) | Render page into a new Texture2D.
Public method | RenderPageToTexture(PDFPage, Int32, Int32, IPDFColoredRectListProvider) | Render page into a new Texture2D.
Public method | RenderPageToTexture(PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRendererRenderSettings) | Render page into a new Texture2D.
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFRenderer Constructor

PDFRenderer Constructor
Initializes a new instance of the PDFRenderer class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFRenderer()
See Also

Reference

PDFRenderer Class


PDFRenderer Methods

PDFRenderer Methods

The PDFRenderer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | RenderPageToByteArray(PDFPage) | Render page into a new byte array.
Public method | RenderPageToByteArray(PDFPage, Int32, Int32) | Render page into a new byte array.
Public method | RenderPageToByteArray(PDFPage, Int32, Int32, IPDFColoredRectListProvider) | Render page into a new byte array.
Public method | RenderPageToByteArray(PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRendererRenderSettings) | Render page into a new byte array.
Public method | RenderPageToExistingTexture(PDFPage, Texture2D) | Render page into an existing Texture2D.
Public method | RenderPageToExistingTexture(PDFPage, Texture2D, IPDFColoredRectListProvider) | Render page into an existing Texture2D.
Public method | RenderPageToExistingTexture(PDFPage, Texture2D, IPDFColoredRectListProvider, PDFRendererRenderSettings) | Render page into an existing Texture2D.
Public method | RenderPageToTexture(PDFPage) | Render page into a new Texture2D.
Public method | RenderPageToTexture(PDFPage, Int32, Int32) | Render page into a new Texture2D.
Public method | RenderPageToTexture(PDFPage, Int32, Int32, IPDFColoredRectListProvider) | Render page into a new Texture2D.
Public method | RenderPageToTexture(PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRendererRenderSettings) | Render page into a new Texture2D.
Top
See Also

Reference

PDFRenderer Class


PDFRenderer.Dispose Method

PDFRendererDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFRenderer
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFRenderer and optionally releases the managed resources
Top
See Also

Reference

PDFRenderer Class


PDFRenderer.Dispose Method

PDFRendererDispose Method
Releases all resources used by the PDFRenderer

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFRenderer Class
Dispose Overload


PDFRenderer.Dispose Method (Boolean)

PDFRendererDispose Method (Boolean)
Releases the unmanaged resources used by the PDFRenderer and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFRenderer Class
Dispose Overload


PDFRenderer.Finalize Method

PDFRendererFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFRenderer Class


PDFRenderer.RenderPageToByteArray Method

PDFRendererRenderPageToByteArray Method
Overload List
 | Name | Description
Public method | RenderPageToByteArray(PDFPage) | Render page into a new byte array.
Public method | RenderPageToByteArray(PDFPage, Int32, Int32) | Render page into a new byte array.
Public method | RenderPageToByteArray(PDFPage, Int32, Int32, IPDFColoredRectListProvider) | Render page into a new byte array.
Public method | RenderPageToByteArray(PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRendererRenderSettings) | Render page into a new byte array.
Top
See Also

Reference

PDFRenderer Class


PDFRenderer.RenderPageToByteArray Method (PDFPage)

PDFRendererRenderPageToByteArray Method (PDFPage)
Render page into a new byte array.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public byte[] RenderPageToByteArray(
    PDFPage page
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage

Return Value

Type: Byte
See Also

Reference

PDFRenderer Class
RenderPageToByteArray Overload


PDFRenderer.RenderPageToByteArray Method (PDFPage, Int32, Int32)

PDFRendererRenderPageToByteArray Method (PDFPage, Int32, Int32)
Render page into a new byte array.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public byte[] RenderPageToByteArray(
    PDFPage page,
    int width,
    int height
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
width
Type: SystemInt32
height
Type: SystemInt32

Return Value

Type: Byte
See Also

Reference

PDFRenderer Class
RenderPageToByteArray Overload


PDFRenderer.RenderPageToByteArray Method (PDFPage, Int32, Int32, IPDFColoredRectListProvider)

PDFRendererRenderPageToByteArray Method (PDFPage, Int32, Int32, IPDFColoredRectListProvider)
Render page into a new byte array.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public byte[] RenderPageToByteArray(
    PDFPage page,
    int width,
    int height,
    IPDFColoredRectListProvider rectsProvider
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
width
Type: SystemInt32
height
Type: SystemInt32
rectsProvider
Type: Paroxe.PdfRendererIPDFColoredRectListProvider

Return Value

Type: Byte
See Also

Reference

PDFRenderer Class
RenderPageToByteArray Overload


PDFRenderer.RenderPageToByteArray Method (PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRenderer.RenderSettings)

PDFRendererRenderPageToByteArray Method (PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRendererRenderSettings)
Render page into a new byte array.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public byte[] RenderPageToByteArray(
    PDFPage page,
    int width,
    int height,
    IPDFColoredRectListProvider rectsProvider,
    PDFRendererRenderSettings settings
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
width
Type: SystemInt32
height
Type: SystemInt32
rectsProvider
Type: Paroxe.PdfRendererIPDFColoredRectListProvider
settings
Type: Paroxe.PdfRendererPDFRendererRenderSettings

Return Value

Type: Byte
See Also

Reference

PDFRenderer Class
RenderPageToByteArray Overload


PDFRenderer.RenderPageToExistingTexture Method

PDFRendererRenderPageToExistingTexture Method
Overload List
 | Name | Description
Public method | RenderPageToExistingTexture(PDFPage, Texture2D) | Render page into an existing Texture2D.
Public method | RenderPageToExistingTexture(PDFPage, Texture2D, IPDFColoredRectListProvider) | Render page into an existing Texture2D.
Public method | RenderPageToExistingTexture(PDFPage, Texture2D, IPDFColoredRectListProvider, PDFRendererRenderSettings) | Render page into an existing Texture2D.
Top
See Also

Reference

PDFRenderer Class


PDFRenderer.RenderPageToExistingTexture Method (PDFPage, Texture2D)

PDFRendererRenderPageToExistingTexture Method (PDFPage, Texture2D)
Render page into an existing Texture2D.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void RenderPageToExistingTexture(
    PDFPage page,
    Texture2D texture
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
texture
Type: Texture2D
See Also

Reference

PDFRenderer Class
RenderPageToExistingTexture Overload


PDFRenderer.RenderPageToExistingTexture Method (PDFPage, Texture2D, IPDFColoredRectListProvider)

PDFRendererRenderPageToExistingTexture Method (PDFPage, Texture2D, IPDFColoredRectListProvider)
Render page into an existing Texture2D.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void RenderPageToExistingTexture(
    PDFPage page,
    Texture2D texture,
    IPDFColoredRectListProvider rectsProvider
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
texture
Type: Texture2D
rectsProvider
Type: Paroxe.PdfRendererIPDFColoredRectListProvider
See Also

Reference

PDFRenderer Class
RenderPageToExistingTexture Overload


PDFRenderer.RenderPageToExistingTexture Method (PDFPage, Texture2D, IPDFColoredRectListProvider, PDFRenderer.RenderSettings)

PDFRendererRenderPageToExistingTexture Method (PDFPage, Texture2D, IPDFColoredRectListProvider, PDFRendererRenderSettings)
Render page into an existing Texture2D.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void RenderPageToExistingTexture(
    PDFPage page,
    Texture2D texture,
    IPDFColoredRectListProvider rectsProvider,
    PDFRendererRenderSettings settings
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
texture
Type: Texture2D
rectsProvider
Type: Paroxe.PdfRendererIPDFColoredRectListProvider
settings
Type: Paroxe.PdfRendererPDFRendererRenderSettings
See Also

Reference

PDFRenderer Class
RenderPageToExistingTexture Overload


PDFRenderer.RenderPageToTexture Method

PDFRendererRenderPageToTexture Method
Overload List
 | Name | Description
Public method | RenderPageToTexture(PDFPage) | Render page into a new Texture2D.
Public method | RenderPageToTexture(PDFPage, Int32, Int32) | Render page into a new Texture2D.
Public method | RenderPageToTexture(PDFPage, Int32, Int32, IPDFColoredRectListProvider) | Render page into a new Texture2D.
Public method | RenderPageToTexture(PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRendererRenderSettings) | Render page into a new Texture2D.
Top
See Also

Reference

PDFRenderer Class


PDFRenderer.RenderPageToTexture Method (PDFPage)

PDFRendererRenderPageToTexture Method (PDFPage)
Render page into a new Texture2D.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Texture2D RenderPageToTexture(
    PDFPage page
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage

Return Value

Type: Texture2D
See Also

Reference

PDFRenderer Class
RenderPageToTexture Overload


PDFRenderer.RenderPageToTexture Method (PDFPage, Int32, Int32)

PDFRendererRenderPageToTexture Method (PDFPage, Int32, Int32)
Render page into a new Texture2D.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Texture2D RenderPageToTexture(
    PDFPage page,
    int width,
    int height
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
width
Type: SystemInt32
height
Type: SystemInt32

Return Value

Type: Texture2D
See Also

Reference

PDFRenderer Class
RenderPageToTexture Overload


PDFRenderer.RenderPageToTexture Method (PDFPage, Int32, Int32, IPDFColoredRectListProvider)

PDFRendererRenderPageToTexture Method (PDFPage, Int32, Int32, IPDFColoredRectListProvider)
Render page into a new Texture2D.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Texture2D RenderPageToTexture(
    PDFPage page,
    int width,
    int height,
    IPDFColoredRectListProvider rectsProvider
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
width
Type: SystemInt32
height
Type: SystemInt32
rectsProvider
Type: Paroxe.PdfRendererIPDFColoredRectListProvider

Return Value

Type: Texture2D
See Also

Reference

PDFRenderer Class
RenderPageToTexture Overload


PDFRenderer.RenderPageToTexture Method (PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRenderer.RenderSettings)

PDFRendererRenderPageToTexture Method (PDFPage, Int32, Int32, IPDFColoredRectListProvider, PDFRendererRenderSettings)
Render page into a new Texture2D.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Texture2D RenderPageToTexture(
    PDFPage page,
    int width,
    int height,
    IPDFColoredRectListProvider rectsProvider,
    PDFRendererRenderSettings settings
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
width
Type: SystemInt32
height
Type: SystemInt32
rectsProvider
Type: Paroxe.PdfRendererIPDFColoredRectListProvider
settings
Type: Paroxe.PdfRendererPDFRendererRenderSettings

Return Value

Type: Texture2D
See Also

Reference

PDFRenderer Class
RenderPageToTexture Overload


PDFRenderer.RenderSettings Class

PDFRendererRenderSettings Class
Allows the application to specify render settings.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFRendererRenderSettings

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RenderSettings

The PDFRendererRenderSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PDFRendererRenderSettings | Initializes a new instance of the PDFRendererRenderSettings class
Top
Properties
Name | Description
defaultRenderSettings |
Top
Methods
 | Name | Description
Public method | ComputeRenderingFlags |
Top
Fields
 | Name | Description
Public field | disableSmoothPath |
Public field | disableSmoothText |
Public field | grayscale |
Public field | optimizeTextForLCDDisplay |
Public field | renderAnnotations |
Public field | renderForPrinting |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFRenderer.RenderSettings Constructor

PDFRendererRenderSettings Constructor
Initializes a new instance of the PDFRendererRenderSettings class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public RenderSettings()
See Also

Reference

PDFRendererRenderSettings Class


RenderSettings Properties

RenderSettings Properties

The PDFRendererRenderSettings type exposes the following members.

Properties
Name | Description
defaultRenderSettings |
Top
See Also

Reference

PDFRendererRenderSettings Class


PDFRenderer.RenderSettings.defaultRenderSettings Property

PDFRendererRenderSettingsdefaultRenderSettings Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public static PDFRendererRenderSettings defaultRenderSettings { get; }

Property Value

Type: PDFRendererRenderSettings
See Also

Reference

PDFRendererRenderSettings Class


RenderSettings Methods

RenderSettings Methods

The PDFRendererRenderSettings type exposes the following members.

Methods
 | Name | Description
Public method | ComputeRenderingFlags |
Top
See Also

Reference

PDFRendererRenderSettings Class


PDFRenderer.RenderSettings.ComputeRenderingFlags Method

PDFRendererRenderSettingsComputeRenderingFlags Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int ComputeRenderingFlags()

Return Value

Type: Int32
See Also

Reference

PDFRendererRenderSettings Class


RenderSettings Fields

RenderSettings Fields

The PDFRendererRenderSettings type exposes the following members.

Fields
 | Name | Description
Public field | disableSmoothPath |
Public field | disableSmoothText |
Public field | grayscale |
Public field | optimizeTextForLCDDisplay |
Public field | renderAnnotations |
Public field | renderForPrinting |
Top
See Also

Reference

PDFRendererRenderSettings Class


PDFRenderer.RenderSettings.disableSmoothPath Field

PDFRendererRenderSettingsdisableSmoothPath Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool disableSmoothPath

Field Value

Type: Boolean
See Also

Reference

PDFRendererRenderSettings Class


PDFRenderer.RenderSettings.disableSmoothText Field

PDFRendererRenderSettingsdisableSmoothText Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool disableSmoothText

Field Value

Type: Boolean
See Also

Reference

PDFRendererRenderSettings Class


PDFRenderer.RenderSettings.grayscale Field

PDFRendererRenderSettingsgrayscale Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool grayscale

Field Value

Type: Boolean
See Also

Reference

PDFRendererRenderSettings Class


PDFRenderer.RenderSettings.optimizeTextForLCDDisplay Field

PDFRendererRenderSettingsoptimizeTextForLCDDisplay Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool optimizeTextForLCDDisplay

Field Value

Type: Boolean
See Also

Reference

PDFRendererRenderSettings Class


PDFRenderer.RenderSettings.renderAnnotations Field

PDFRendererRenderSettingsrenderAnnotations Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool renderAnnotations

Field Value

Type: Boolean
See Also

Reference

PDFRendererRenderSettings Class


PDFRenderer.RenderSettings.renderForPrinting Field

PDFRendererRenderSettingsrenderForPrinting Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool renderForPrinting

Field Value

Type: Boolean
See Also

Reference

PDFRendererRenderSettings Class


PDFSearchHandle Class

PDFSearchHandle Class
Represent a search session within a specific page. To search in entire document use PDFTextPage.Search
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFSearchHandle

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFSearchHandle : IDisposable

The PDFSearchHandle type exposes the following members.

Constructors
 | Name | Description
Public method | PDFSearchHandle | Initializes a new instance of the PDFSearchHandle class
Top
Properties
 | Name | Description
Public property | NativePointer |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFSearchHandle
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFSearchHandle and optionally releases the managed resources
Public method | EnumerateSearchResults | Enumerate search results.
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | FindNext | Get the next search result. If there is no other result, the function returns an invalid searchResult (validate it with PDFSearchResult.IsValid)
Public method | FindPrevious | Get the previous search result. If there is no other result, the function returns an invalid searchResult (validate it with PDFSearchResult.IsValid)
Public method | GetResults | Return an array containing all the searchResults. If there is no result, this function return null.
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFSearchHandle Constructor

PDFSearchHandle Constructor
Initializes a new instance of the PDFSearchHandle class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFSearchHandle(
    PDFTextPage textPage,
    byte[] findWhatUnicode,
    int startIndex,
    PDFSearchHandleMatchOption flags = PDFSearchHandleMatchOption.NONE
)

Parameters

textPage
Type: Paroxe.PdfRendererPDFTextPage
findWhatUnicode
Type: SystemByte
startIndex
Type: SystemInt32
flags (Optional)
Type: Paroxe.PdfRendererPDFSearchHandleMatchOption
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle Properties

PDFSearchHandle Properties

The PDFSearchHandle type exposes the following members.

Properties
 | Name | Description
Public property | NativePointer |
Top
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle.NativePointer Property

PDFSearchHandleNativePointer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IntPtr NativePointer { get; }

Property Value

Type: IntPtr
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle Methods

PDFSearchHandle Methods

The PDFSearchHandle type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | EnumerateSearchResults | Enumerate search results.
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | FindNext | Get the next search result. If there is no other result, the function returns an invalid searchResult (validate it with PDFSearchResult.IsValid)
Public method | FindPrevious | Get the previous search result. If there is no other result, the function returns an invalid searchResult (validate it with PDFSearchResult.IsValid)
Public method | GetResults | Return an array containing all the searchResults. If there is no result, this function return null.
Top
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle.Dispose Method

PDFSearchHandleDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFSearchHandle
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFSearchHandle and optionally releases the managed resources
Top
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle.Dispose Method

PDFSearchHandleDispose Method
Releases all resources used by the PDFSearchHandle

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFSearchHandle Class
Dispose Overload


PDFSearchHandle.Dispose Method (Boolean)

PDFSearchHandleDispose Method (Boolean)
Releases the unmanaged resources used by the PDFSearchHandle and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFSearchHandle Class
Dispose Overload


PDFSearchHandle.EnumerateSearchResults Method

PDFSearchHandleEnumerateSearchResults Method
Enumerate search results.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IEnumerable<PDFSearchResult> EnumerateSearchResults()

Return Value

Type: IEnumerable PDFSearchResult
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle.Finalize Method

PDFSearchHandleFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle.FindNext Method

PDFSearchHandleFindNext Method
Get the next search result. If there is no other result, the function returns an invalid searchResult (validate it with PDFSearchResult.IsValid)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFSearchResult FindNext()

Return Value

Type: PDFSearchResult
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle.FindPrevious Method

PDFSearchHandleFindPrevious Method
Get the previous search result. If there is no other result, the function returns an invalid searchResult (validate it with PDFSearchResult.IsValid)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFSearchResult FindPrevious()

Return Value

Type: PDFSearchResult
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle.GetResults Method

PDFSearchHandleGetResults Method
Return an array containing all the searchResults. If there is no result, this function return null.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IList<PDFSearchResult> GetResults()

Return Value

Type: IList PDFSearchResult
See Also

Reference

PDFSearchHandle Class


PDFSearchHandle.MatchOption Enumeration

PDFSearchHandleMatchOption Enumeration

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public enum MatchOption
Members
Member name | Value | Description
NONE | 0 |
MATCH_CASE | 1 |
MATCH_WHOLE_WORD | 2 |
MATCH_CASE_AND_WHOLE_WORD | 3 |
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFSearchResult Structure

PDFSearchResult Structure
Reprensent a search result. To result location is describe with index of the first char and the length of the result.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public struct PDFSearchResult

The PDFSearchResult type exposes the following members.

Constructors
 | Name | Description
Public method | PDFSearchResult | Initializes a new instance of the PDFSearchResult class
Top
Properties
 | Name | Description
Public property | Count | The length of the result within the page.
Public property | IsValid | Indicate whether the result is valid or invalid.
Public property | PageIndex | The pageIndex of the result.
Public property | StartIndex | The index of the first character of the result within the page.
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFSearchResult Constructor

PDFSearchResult Constructor
Initializes a new instance of the PDFSearchResult class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFSearchResult(
    int pageIndex,
    int startIndex,
    int count
)

Parameters

pageIndex
Type: SystemInt32
startIndex
Type: SystemInt32
count
Type: SystemInt32
See Also

Reference

PDFSearchResult Structure


PDFSearchResult Properties

PDFSearchResult Properties

The PDFSearchResult type exposes the following members.

Properties
 | Name | Description
Public property | Count | The length of the result within the page.
Public property | IsValid | Indicate whether the result is valid or invalid.
Public property | PageIndex | The pageIndex of the result.
Public property | StartIndex | The index of the first character of the result within the page.
Top
See Also

Reference

PDFSearchResult Structure


PDFSearchResult.Count Property

PDFSearchResultCount Property
The length of the result within the page.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int Count { get; }

Property Value

Type: Int32
See Also

Reference

PDFSearchResult Structure


PDFSearchResult.IsValid Property

PDFSearchResultIsValid Property
Indicate whether the result is valid or invalid.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool IsValid { get; }

Property Value

Type: Boolean
See Also

Reference

PDFSearchResult Structure


PDFSearchResult.PageIndex Property

PDFSearchResultPageIndex Property
The pageIndex of the result.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int PageIndex { get; }

Property Value

Type: Int32
See Also

Reference

PDFSearchResult Structure


PDFSearchResult.StartIndex Property

PDFSearchResultStartIndex Property
The index of the first character of the result within the page.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int StartIndex { get; }

Property Value

Type: Int32
See Also

Reference

PDFSearchResult Structure


PDFTextPage Class

PDFTextPage Class
This class allow to access the text of a page.
Inheritance Hierarchy
SystemObject
Paroxe.PdfRendererPDFTextPage

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFTextPage : IDisposable,
    IEquatable<PDFTextPage>

The PDFTextPage type exposes the following members.

Constructors
 | Name | Description
Public method | PDFTextPage | Initializes a new instance of the PDFTextPage class
Top
Properties
 | Name | Description
Public property | NativePointer |
Public property | Page | Return a refence to the page.
Public property | PageIndex | Return the page index of the text.
Top
Methods
 | Name | Description
Public method | CountChars | Return the number of character in the page.
Public method | CountRects | Count number of rectangular areas occupied by a segment of texts.
Public method | Dispose | Releases all resources used by the PDFTextPage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFTextPage and optionally releases the managed resources
Public method | Equals |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetBoundedText | Extract text within a rectangular boundary on the page.
Public method | GetChar | Get a character in the page.
Public method | GetCharBox | Get bounding box of a particular character.
Public method | GetCharIndexAtPos | Get the index of a character at or nearby a certain position on the page.
Public method | GetFontSize | Get the font size of a particular character.
Public method | GetRect | Get a rectangular area from the result generated by CountRects
Public method | GetText | Extract text string from the page.
Public method | Search(Byte, PDFSearchHandleMatchOption, Int32) |
Public method | Search(String, PDFSearchHandleMatchOption, Int32) |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFTextPage Constructor

PDFTextPage Constructor
Initializes a new instance of the PDFTextPage class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFTextPage(
    PDFPage page
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage
See Also

Reference

PDFTextPage Class


PDFTextPage Properties

PDFTextPage Properties

The PDFTextPage type exposes the following members.

Properties
 | Name | Description
Public property | NativePointer |
Public property | Page | Return a refence to the page.
Public property | PageIndex | Return the page index of the text.
Top
See Also

Reference

PDFTextPage Class


PDFTextPage.NativePointer Property

PDFTextPageNativePointer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IntPtr NativePointer { get; }

Property Value

Type: IntPtr
See Also

Reference

PDFTextPage Class


PDFTextPage.Page Property

PDFTextPagePage Property
Return a refence to the page.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFPage Page { get; }

Property Value

Type: PDFPage
See Also

Reference

PDFTextPage Class


PDFTextPage.PageIndex Property

PDFTextPagePageIndex Property
Return the page index of the text.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int PageIndex { get; }

Property Value

Type: Int32
See Also

Reference

PDFTextPage Class


PDFTextPage Methods

PDFTextPage Methods

The PDFTextPage type exposes the following members.

Methods
 | Name | Description
Public method | CountChars | Return the number of character in the page.
Public method | CountRects | Count number of rectangular areas occupied by a segment of texts.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals |
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetBoundedText | Extract text within a rectangular boundary on the page.
Public method | GetChar | Get a character in the page.
Public method | GetCharBox | Get bounding box of a particular character.
Public method | GetCharIndexAtPos | Get the index of a character at or nearby a certain position on the page.
Public method | GetFontSize | Get the font size of a particular character.
Public method | GetRect | Get a rectangular area from the result generated by CountRects
Public method | GetText | Extract text string from the page.
Public method | Search(Byte, PDFSearchHandleMatchOption, Int32) |
Public method | Search(String, PDFSearchHandleMatchOption, Int32) |
Top
See Also

Reference

PDFTextPage Class


PDFTextPage.CountChars Method

PDFTextPageCountChars Method
Return the number of character in the page.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int CountChars()

Return Value

Type: Int32
See Also

Reference

PDFTextPage Class


PDFTextPage.CountRects Method

PDFTextPageCountRects Method
Count number of rectangular areas occupied by a segment of texts.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int CountRects(
    int startIndex,
    int count
)

Parameters

startIndex
Type: SystemInt32
count
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

PDFTextPage Class


PDFTextPage.Dispose Method

PDFTextPageDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFTextPage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PDFTextPage and optionally releases the managed resources
Top
See Also

Reference

PDFTextPage Class


PDFTextPage.Dispose Method

PDFTextPageDispose Method
Releases all resources used by the PDFTextPage

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

PDFTextPage Class
Dispose Overload


PDFTextPage.Dispose Method (Boolean)

PDFTextPageDispose Method (Boolean)
Releases the unmanaged resources used by the PDFTextPage and optionally releases the managed resources

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PDFTextPage Class
Dispose Overload


PDFTextPage.Equals Method

PDFTextPageEquals Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool Equals(
    PDFTextPage other
)

Parameters

other
Type: Paroxe.PdfRendererPDFTextPage

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

PDFTextPage Class


PDFTextPage.Finalize Method

PDFTextPageFinalize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

PDFTextPage Class


PDFTextPage.GetBoundedText Method

PDFTextPageGetBoundedText Method
Extract text within a rectangular boundary on the page.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string GetBoundedText(
    Rect rect,
    int charCount
)

Parameters

rect
Type: Rect
charCount
Type: SystemInt32

Return Value

Type: String
See Also

Reference

PDFTextPage Class


PDFTextPage.GetChar Method

PDFTextPageGetChar Method
Get a character in the page.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string GetChar(
    int charIndex
)

Parameters

charIndex
Type: SystemInt32

Return Value

Type: String
See Also

Reference

PDFTextPage Class


PDFTextPage.GetCharBox Method

PDFTextPageGetCharBox Method
Get bounding box of a particular character.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Rect GetCharBox(
    int charIndex
)

Parameters

charIndex
Type: SystemInt32

Return Value

Type: Rect
See Also

Reference

PDFTextPage Class


PDFTextPage.GetCharIndexAtPos Method

PDFTextPageGetCharIndexAtPos Method
Get the index of a character at or nearby a certain position on the page.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int GetCharIndexAtPos(
    Vector2 pos,
    Vector2 tolerance
)

Parameters

pos
Type: Vector2
tolerance
Type: Vector2

Return Value

Type: Int32
See Also

Reference

PDFTextPage Class


PDFTextPage.GetFontSize Method

PDFTextPageGetFontSize Method
Get the font size of a particular character.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public double GetFontSize(
    int charIndex
)

Parameters

charIndex
Type: SystemInt32

Return Value

Type: Double
See Also

Reference

PDFTextPage Class


PDFTextPage.GetRect Method

PDFTextPageGetRect Method
Get a rectangular area from the result generated by CountRects

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Rect GetRect(
    int rectIndex
)

Parameters

rectIndex
Type: SystemInt32

Return Value

Type: Rect
See Also

Reference

PDFTextPage Class


PDFTextPage.GetText Method

PDFTextPageGetText Method
Extract text string from the page.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string GetText(
    int startIndex,
    int count
)

Parameters

startIndex
Type: SystemInt32
count
Type: SystemInt32

Return Value

Type: String
See Also

Reference

PDFTextPage Class


PDFTextPage.Search Method

PDFTextPageSearch Method
Overload List
 | Name | Description
Public method | Search(Byte, PDFSearchHandleMatchOption, Int32) |
Public method | Search(String, PDFSearchHandleMatchOption, Int32) |
Top
See Also

Reference

PDFTextPage Class


PDFTextPage.Search Method (Byte[], PDFSearchHandle.MatchOption, Int32)

PDFTextPageSearch Method (Byte, PDFSearchHandleMatchOption, Int32)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IList<PDFSearchResult> Search(
    byte[] findWhatUnicode,
    PDFSearchHandleMatchOption flags = PDFSearchHandleMatchOption.NONE,
    int startIndex = 0
)

Parameters

findWhatUnicode
Type: SystemByte
flags (Optional)
Type: Paroxe.PdfRendererPDFSearchHandleMatchOption
startIndex (Optional)
Type: SystemInt32

Return Value

Type: IList PDFSearchResult
See Also

Reference

PDFTextPage Class
Search Overload


PDFTextPage.Search Method (String, PDFSearchHandle.MatchOption, Int32)

PDFTextPageSearch Method (String, PDFSearchHandleMatchOption, Int32)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IList<PDFSearchResult> Search(
    string findWhat,
    PDFSearchHandleMatchOption flags = PDFSearchHandleMatchOption.NONE,
    int startIndex = 0
)

Parameters

findWhat
Type: SystemString
flags (Optional)
Type: Paroxe.PdfRendererPDFSearchHandleMatchOption
startIndex (Optional)
Type: SystemInt32

Return Value

Type: IList PDFSearchResult
See Also

Reference

PDFTextPage Class
Search Overload


PDFViewer Class

PDFViewer Class
PDFViewer is an Unity UI component that allow you to visualize PDF Document.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
UIBehaviour
Paroxe.PdfRendererPDFViewer

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public class PDFViewer : UIBehaviour, IPDFDevice,
    IPDFColoredRectListProvider

The PDFViewer type exposes the following members.

Constructors
 | Name | Description
Public method | PDFViewer | Initializes a new instance of the PDFViewer class
Top
Properties
 | Name | Description
Public property | AllowOpenURL | Specify if the PDFViewer can open url link with external browser.
Public property | BackgroundColor | Specify the viewport background color.
Public property | BookmarksActionHandler | Specify the action handler for bookmarks.
Public property | BytesSupplierComponent | This property is intended to be used along side with the bytes file source. (FileSource.Bytes) Specify from which component the byte suplier function resides.
Public property | BytesSupplierFunctionName | This property is intended to be used along side with the bytes file source. (FileSource.Bytes) Specify the function name whithin the byte supplier component.
Public property | BytesSupplierObject | This property is intended to be used along side with the bytes file source. (FileSource.Bytes) Specify the object in which the bytes suppliers component resides.
Public property | CurrentPageIndex |
Public property | CurrentSearchResultIndex |
Public property | DataBuffer | Return the byte array of the current loaded pdf document.
Public property | Document |
Public property | FileName |
Public property | FilePath |
Public property | FileSource |
Public property | FileURL |
Public property | Folder |
Public property | IsLoaded |
Public property | LinksActionHandler | Specify the action handler for links.
Public property | LoadOnEnable |
Public property | MaxZoomFactor |
Public property | MaxZoomFactorTextureQuality |
Public property | MinZoomFactor |
Public property | PageFitting |
Public property | Password |
Public property | PDFAsset | Intended to be used along side the Asset file source (FileSource.Asset)
Public property | RenderAnnotations |
Public property | RenderGrayscale |
Public property | ScrollSensitivity |
Public property | SearchResultColor |
Public property | SearchResultPadding |
Public property | SearchTimeBudgetPerFrame | Specify the relative amount of time is allowed for text search per frame (0.0f to 1.0f).
Public property | ShowBookmarksViewer |
Public property | ShowHorizontalScrollBar |
Public property | ShowThumbnailsViewer |
Public property | ShowTopBar |
Public property | ShowVerticalScrollBar |
Public property | UnloadOnDisable |
Public property | VerticalMarginBetweenPages |
Public property | ZoomFactor |
Public property | ZoomStep |
Top
Methods
 | Name | Description
Public method | AdjustZoomToPageFitting |
Public method | CloseDocument |
Public method | GetBackgroundColoredRectList |
Public method | GetBookmarksActionHandler |
Public method | GetDevicePageSize |
Public method | GetFileLocation |
Public method | GetLinksActionHandler |
Public method | GetLoadedDocument |
Public method | GoToNextPage |
Public method | GoToNextSearchResult |
Public method | GoToPage |
Public method | GoToPreviousPage |
Public method | GoToPreviousSearchResult |
Public method | LoadDocument(Int32) |
Public method | LoadDocument(PDFDocument, Int32) |
Public method | LoadDocument(PDFDocument, String, Int32) |
Public method | LoadDocumentFromAsset(PDFAsset, Int32) |
Public method | LoadDocumentFromAsset(PDFAsset, String, Int32) |
Public method | LoadDocumentFromResources |
Public method | LoadDocumentFromStreamingAssets |
Public method | LoadDocumentFromWeb |
Public method | LoadDocumentWithBuffer |
Public method | LoadDocumentWithFile |
Protected method | OnDisable | (Overrides UIBehaviour.OnDisable.)
Public method | OnDownloadCancelButtonClicked |
Protected method | OnEnable | (Overrides UIBehaviour.OnEnable.)
Public method | OnPageEditEnd |
Public method | OnPasswordDialogCancelButtonClicked |
Public method | OnPasswordDialogOkButtonClicked |
Public method | ReloadDocument |
Public method | SaveDocumentAsFile |
Public method | SetSearchResults |
Protected method | Start | (Overrides UIBehaviour.Start.)
Public method | UnloadDocument |
Public method | ZoomIn |
Public method | ZoomOut |
Top
Events
 | Name | Description
Public event | OnCurrentPageChanged |
Public event | OnDisabled |
Public event | OnDocumentLoaded |
Public event | OnDocumentLoadFailed |
Public event | OnDocumentUnloaded |
Public event | OnDownloadCancelled |
Public event | OnPasswordCancelled |
Public event | OnZoomChanged |
Top
Fields
 | Name | Description
Public field | m_Internal |
Top
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFViewer Constructor

PDFViewer Constructor
Initializes a new instance of the PDFViewer class

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFViewer()
See Also

Reference

PDFViewer Class


PDFViewer Properties

PDFViewer Properties

The PDFViewer type exposes the following members.

Properties
 | Name | Description
Public property | AllowOpenURL | Specify if the PDFViewer can open url link with external browser.
Public property | BackgroundColor | Specify the viewport background color.
Public property | BookmarksActionHandler | Specify the action handler for bookmarks.
Public property | BytesSupplierComponent | This property is intended to be used along side with the bytes file source. (FileSource.Bytes) Specify from which component the byte suplier function resides.
Public property | BytesSupplierFunctionName | This property is intended to be used along side with the bytes file source. (FileSource.Bytes) Specify the function name whithin the byte supplier component.
Public property | BytesSupplierObject | This property is intended to be used along side with the bytes file source. (FileSource.Bytes) Specify the object in which the bytes suppliers component resides.
Public property | CurrentPageIndex |
Public property | CurrentSearchResultIndex |
Public property | DataBuffer | Return the byte array of the current loaded pdf document.
Public property | Document |
Public property | FileName |
Public property | FilePath |
Public property | FileSource |
Public property | FileURL |
Public property | Folder |
Public property | IsLoaded |
Public property | LinksActionHandler | Specify the action handler for links.
Public property | LoadOnEnable |
Public property | MaxZoomFactor |
Public property | MaxZoomFactorTextureQuality |
Public property | MinZoomFactor |
Public property | PageFitting |
Public property | Password |
Public property | PDFAsset | Intended to be used along side the Asset file source (FileSource.Asset)
Public property | RenderAnnotations |
Public property | RenderGrayscale |
Public property | ScrollSensitivity |
Public property | SearchResultColor |
Public property | SearchResultPadding |
Public property | SearchTimeBudgetPerFrame | Specify the relative amount of time is allowed for text search per frame (0.0f to 1.0f).
Public property | ShowBookmarksViewer |
Public property | ShowHorizontalScrollBar |
Public property | ShowThumbnailsViewer |
Public property | ShowTopBar |
Public property | ShowVerticalScrollBar |
Public property | UnloadOnDisable |
Public property | VerticalMarginBetweenPages |
Public property | ZoomFactor |
Public property | ZoomStep |
Top
See Also

Reference

PDFViewer Class


PDFViewer.AllowOpenURL Property

PDFViewerAllowOpenURL Property
Specify if the PDFViewer can open url link with external browser.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool AllowOpenURL { get; set; }

Property Value

Type: Boolean

Implements

IPDFDeviceAllowOpenURL
See Also

Reference

PDFViewer Class


PDFViewer.BackgroundColor Property

PDFViewerBackgroundColor Property
Specify the viewport background color.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Color BackgroundColor { get; set; }

Property Value

Type: Color
See Also

Reference

PDFViewer Class


PDFViewer.BookmarksActionHandler Property

PDFViewerBookmarksActionHandler Property
Specify the action handler for bookmarks.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IPDFDeviceActionHandler BookmarksActionHandler { get; set; }

Property Value

Type: IPDFDeviceActionHandler

Implements

IPDFDeviceBookmarksActionHandler
See Also

Reference

PDFViewer Class


PDFViewer.BytesSupplierComponent Property

PDFViewerBytesSupplierComponent Property
This property is intended to be used along side with the bytes file source. (FileSource.Bytes) Specify from which component the byte suplier function resides.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Component BytesSupplierComponent { get; set; }

Property Value

Type: Component
See Also

Reference

PDFViewer Class


PDFViewer.BytesSupplierFunctionName Property

PDFViewerBytesSupplierFunctionName Property
This property is intended to be used along side with the bytes file source. (FileSource.Bytes) Specify the function name whithin the byte supplier component.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string BytesSupplierFunctionName { get; set; }

Property Value

Type: String
See Also

Reference

PDFViewer Class


PDFViewer.BytesSupplierObject Property

PDFViewerBytesSupplierObject Property
This property is intended to be used along side with the bytes file source. (FileSource.Bytes) Specify the object in which the bytes suppliers component resides.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public GameObject BytesSupplierObject { get; set; }

Property Value

Type: GameObject
See Also

Reference

PDFViewer Class


PDFViewer.CurrentPageIndex Property

PDFViewerCurrentPageIndex Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int CurrentPageIndex { get; set; }

Property Value

Type: Int32
See Also

Reference

PDFViewer Class


PDFViewer.CurrentSearchResultIndex Property

PDFViewerCurrentSearchResultIndex Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public int CurrentSearchResultIndex { get; }

Property Value

Type: Int32
See Also

Reference

PDFViewer Class


PDFViewer.DataBuffer Property

PDFViewerDataBuffer Property
Return the byte array of the current loaded pdf document.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public byte[] DataBuffer { get; }

Property Value

Type: Byte
See Also

Reference

PDFViewer Class


PDFViewer.Document Property

PDFViewerDocument Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument Document { get; }

Property Value

Type: PDFDocument
See Also

Reference

PDFViewer Class


PDFViewer.FileName Property

PDFViewerFileName Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string FileName { get; set; }

Property Value

Type: String
See Also

Reference

PDFViewer Class


PDFViewer.FilePath Property

PDFViewerFilePath Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string FilePath { get; set; }

Property Value

Type: String
See Also

Reference

PDFViewer Class


PDFViewer.FileSource Property

PDFViewerFileSource Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFViewerFileSourceType FileSource { get; set; }

Property Value

Type: PDFViewerFileSourceType
See Also

Reference

PDFViewer Class


PDFViewer.FileURL Property

PDFViewerFileURL Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string FileURL { get; set; }

Property Value

Type: String
See Also

Reference

PDFViewer Class


PDFViewer.Folder Property

PDFViewerFolder Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string Folder { get; set; }

Property Value

Type: String
See Also

Reference

PDFViewer Class


PDFViewer.IsLoaded Property

PDFViewerIsLoaded Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool IsLoaded { get; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.LinksActionHandler Property

PDFViewerLinksActionHandler Property
Specify the action handler for links.

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IPDFDeviceActionHandler LinksActionHandler { get; set; }

Property Value

Type: IPDFDeviceActionHandler

Implements

IPDFDeviceLinksActionHandler
See Also

Reference

PDFViewer Class


PDFViewer.LoadOnEnable Property

PDFViewerLoadOnEnable Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool LoadOnEnable { get; set; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.MaxZoomFactor Property

PDFViewerMaxZoomFactor Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public float MaxZoomFactor { get; set; }

Property Value

Type: Single
See Also

Reference

PDFViewer Class


PDFViewer.MaxZoomFactorTextureQuality Property

PDFViewerMaxZoomFactorTextureQuality Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public float MaxZoomFactorTextureQuality { get; set; }

Property Value

Type: Single
See Also

Reference

PDFViewer Class


PDFViewer.MinZoomFactor Property

PDFViewerMinZoomFactor Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public float MinZoomFactor { get; set; }

Property Value

Type: Single
See Also

Reference

PDFViewer Class


PDFViewer.PageFitting Property

PDFViewerPageFitting Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFViewerPageFittingType PageFitting { get; set; }

Property Value

Type: PDFViewerPageFittingType
See Also

Reference

PDFViewer Class


PDFViewer.Password Property

PDFViewerPassword Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string Password { get; set; }

Property Value

Type: String
See Also

Reference

PDFViewer Class


PDFViewer.PDFAsset Property

PDFViewerPDFAsset Property
Intended to be used along side the Asset file source (FileSource.Asset)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFAsset PDFAsset { get; set; }

Property Value

Type: PDFAsset
See Also

Reference

PDFViewer Class


PDFViewer.RenderAnnotations Property

PDFViewerRenderAnnotations Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool RenderAnnotations { get; set; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.RenderGrayscale Property

PDFViewerRenderGrayscale Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool RenderGrayscale { get; set; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.ScrollSensitivity Property

PDFViewerScrollSensitivity Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public float ScrollSensitivity { get; set; }

Property Value

Type: Single
See Also

Reference

PDFViewer Class


PDFViewer.SearchResultColor Property

PDFViewerSearchResultColor Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Color SearchResultColor { get; set; }

Property Value

Type: Color
See Also

Reference

PDFViewer Class


PDFViewer.SearchResultPadding Property

PDFViewerSearchResultPadding Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Vector2 SearchResultPadding { get; set; }

Property Value

Type: Vector2
See Also

Reference

PDFViewer Class


PDFViewer.SearchTimeBudgetPerFrame Property

PDFViewerSearchTimeBudgetPerFrame Property
Specify the relative amount of time is allowed for text search per frame (0.0f to 1.0f).

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public float SearchTimeBudgetPerFrame { get; set; }

Property Value

Type: Single
See Also

Reference

PDFViewer Class


PDFViewer.ShowBookmarksViewer Property

PDFViewerShowBookmarksViewer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool ShowBookmarksViewer { get; set; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.ShowHorizontalScrollBar Property

PDFViewerShowHorizontalScrollBar Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool ShowHorizontalScrollBar { get; set; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.ShowThumbnailsViewer Property

PDFViewerShowThumbnailsViewer Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool ShowThumbnailsViewer { get; set; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.ShowTopBar Property

PDFViewerShowTopBar Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool ShowTopBar { get; set; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.ShowVerticalScrollBar Property

PDFViewerShowVerticalScrollBar Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool ShowVerticalScrollBar { get; set; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.UnloadOnDisable Property

PDFViewerUnloadOnDisable Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool UnloadOnDisable { get; set; }

Property Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.VerticalMarginBetweenPages Property

PDFViewerVerticalMarginBetweenPages Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public float VerticalMarginBetweenPages { get; set; }

Property Value

Type: Single
See Also

Reference

PDFViewer Class


PDFViewer.ZoomFactor Property

PDFViewerZoomFactor Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public float ZoomFactor { get; set; }

Property Value

Type: Single
See Also

Reference

PDFViewer Class


PDFViewer.ZoomStep Property

PDFViewerZoomStep Property

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public float ZoomStep { get; set; }

Property Value

Type: Single
See Also

Reference

PDFViewer Class


PDFViewer Methods

PDFViewer Methods

The PDFViewer type exposes the following members.

Methods
 | Name | Description
Public method | AdjustZoomToPageFitting |
Public method | CloseDocument |
Public method | GetBackgroundColoredRectList |
Public method | GetBookmarksActionHandler |
Public method | GetDevicePageSize |
Public method | GetFileLocation |
Public method | GetLinksActionHandler |
Public method | GetLoadedDocument |
Public method | GoToNextPage |
Public method | GoToNextSearchResult |
Public method | GoToPage |
Public method | GoToPreviousPage |
Public method | GoToPreviousSearchResult |
Public method | LoadDocument(Int32) |
Public method | LoadDocument(PDFDocument, Int32) |
Public method | LoadDocument(PDFDocument, String, Int32) |
Public method | LoadDocumentFromAsset(PDFAsset, Int32) |
Public method | LoadDocumentFromAsset(PDFAsset, String, Int32) |
Public method | LoadDocumentFromResources |
Public method | LoadDocumentFromStreamingAssets |
Public method | LoadDocumentFromWeb |
Public method | LoadDocumentWithBuffer |
Public method | LoadDocumentWithFile |
Protected method | OnDisable | (Overrides UIBehaviour.OnDisable.)
Public method | OnDownloadCancelButtonClicked |
Protected method | OnEnable | (Overrides UIBehaviour.OnEnable.)
Public method | OnPageEditEnd |
Public method | OnPasswordDialogCancelButtonClicked |
Public method | OnPasswordDialogOkButtonClicked |
Public method | ReloadDocument |
Public method | SaveDocumentAsFile |
Public method | SetSearchResults |
Protected method | Start | (Overrides UIBehaviour.Start.)
Public method | UnloadDocument |
Public method | ZoomIn |
Public method | ZoomOut |
Top
See Also

Reference

PDFViewer Class


PDFViewer.AdjustZoomToPageFitting Method

PDFViewerAdjustZoomToPageFitting Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void AdjustZoomToPageFitting(
    PDFViewerPageFittingType pageFitting,
    Vector2 referencePageSize
)

Parameters

pageFitting
Type: Paroxe.PdfRendererPDFViewerPageFittingType
referencePageSize
Type: Vector2
See Also

Reference

PDFViewer Class


PDFViewer.CloseDocument Method

PDFViewerCloseDocument Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void CloseDocument()
See Also

Reference

PDFViewer Class


PDFViewer.GetBackgroundColoredRectList Method

PDFViewerGetBackgroundColoredRectList Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IList<PDFColoredRect> GetBackgroundColoredRectList(
    PDFPage page
)

Parameters

page
Type: Paroxe.PdfRendererPDFPage

Return Value

Type: IList PDFColoredRect

Implements

IPDFColoredRectListProviderGetBackgroundColoredRectList(PDFPage)
See Also

Reference

PDFViewer Class


PDFViewer.GetBookmarksActionHandler Method

PDFViewerGetBookmarksActionHandler Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IPDFDeviceActionHandler GetBookmarksActionHandler()

Return Value

Type: IPDFDeviceActionHandler
See Also

Reference

PDFViewer Class


PDFViewer.GetDevicePageSize Method

PDFViewerGetDevicePageSize Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public Vector2 GetDevicePageSize(
    int pageIndex
)

Parameters

pageIndex
Type: SystemInt32

Return Value

Type: Vector2

Implements

IPDFDeviceGetDevicePageSize(Int32)
See Also

Reference

PDFViewer Class


PDFViewer.GetFileLocation Method

PDFViewerGetFileLocation Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public string GetFileLocation()

Return Value

Type: String
See Also

Reference

PDFViewer Class


PDFViewer.GetLinksActionHandler Method

PDFViewerGetLinksActionHandler Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public IPDFDeviceActionHandler GetLinksActionHandler()

Return Value

Type: IPDFDeviceActionHandler
See Also

Reference

PDFViewer Class


PDFViewer.GetLoadedDocument Method

PDFViewerGetLoadedDocument Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFDocument GetLoadedDocument()

Return Value

Type: PDFDocument

Implements

IPDFDeviceGetLoadedDocument
See Also

Reference

PDFViewer Class


PDFViewer.GoToNextPage Method

PDFViewerGoToNextPage Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void GoToNextPage()
See Also

Reference

PDFViewer Class


PDFViewer.GoToNextSearchResult Method

PDFViewerGoToNextSearchResult Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void GoToNextSearchResult()
See Also

Reference

PDFViewer Class


PDFViewer.GoToPage Method

PDFViewerGoToPage Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void GoToPage(
    int pageIndex
)

Parameters

pageIndex
Type: SystemInt32

Implements

IPDFDeviceGoToPage(Int32)
See Also

Reference

PDFViewer Class


PDFViewer.GoToPreviousPage Method

PDFViewerGoToPreviousPage Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void GoToPreviousPage()
See Also

Reference

PDFViewer Class


PDFViewer.GoToPreviousSearchResult Method

PDFViewerGoToPreviousSearchResult Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void GoToPreviousSearchResult()
See Also

Reference

PDFViewer Class


PDFViewer.LoadDocument Method

PDFViewerLoadDocument Method
Overload List
 | Name | Description
Public method | LoadDocument(Int32) |
Public method | LoadDocument(PDFDocument, Int32) |
Public method | LoadDocument(PDFDocument, String, Int32) |
Top
See Also

Reference

PDFViewer Class


PDFViewer.LoadDocument Method (Int32)

PDFViewerLoadDocument Method (Int32)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocument(
    int pageIndex = 0
)

Parameters

pageIndex (Optional)
Type: SystemInt32
See Also

Reference

PDFViewer Class
LoadDocument Overload


PDFViewer.LoadDocument Method (PDFDocument, Int32)

PDFViewerLoadDocument Method (PDFDocument, Int32)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocument(
    PDFDocument document,
    int pageIndex = 0
)

Parameters

document
Type: Paroxe.PdfRendererPDFDocument
pageIndex (Optional)
Type: SystemInt32
See Also

Reference

PDFViewer Class
LoadDocument Overload


PDFViewer.LoadDocument Method (PDFDocument, String, Int32)

PDFViewerLoadDocument Method (PDFDocument, String, Int32)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocument(
    PDFDocument document,
    string password,
    int pageIndex
)

Parameters

document
Type: Paroxe.PdfRendererPDFDocument
password
Type: SystemString
pageIndex
Type: SystemInt32

Implements

IPDFDeviceLoadDocument(PDFDocument, String, Int32)
See Also

Reference

PDFViewer Class
LoadDocument Overload


PDFViewer.LoadDocumentFromAsset Method

PDFViewerLoadDocumentFromAsset Method
Overload List
 | Name | Description
Public method | LoadDocumentFromAsset(PDFAsset, Int32) |
Public method | LoadDocumentFromAsset(PDFAsset, String, Int32) |
Top
See Also

Reference

PDFViewer Class


PDFViewer.LoadDocumentFromAsset Method (PDFAsset, Int32)

PDFViewerLoadDocumentFromAsset Method (PDFAsset, Int32)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocumentFromAsset(
    PDFAsset pdfAsset,
    int pageIndex = 0
)

Parameters

pdfAsset
Type: Paroxe.PdfRendererPDFAsset
pageIndex (Optional)
Type: SystemInt32

Implements

IPDFDeviceLoadDocumentFromAsset(PDFAsset, Int32)
See Also

Reference

PDFViewer Class
LoadDocumentFromAsset Overload


PDFViewer.LoadDocumentFromAsset Method (PDFAsset, String, Int32)

PDFViewerLoadDocumentFromAsset Method (PDFAsset, String, Int32)

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocumentFromAsset(
    PDFAsset pdfAsset,
    string password,
    int pageIndex = 0
)

Parameters

pdfAsset
Type: Paroxe.PdfRendererPDFAsset
password
Type: SystemString
pageIndex (Optional)
Type: SystemInt32

Implements

IPDFDeviceLoadDocumentFromAsset(PDFAsset, String, Int32)
See Also

Reference

PDFViewer Class
LoadDocumentFromAsset Overload


PDFViewer.LoadDocumentFromResources Method

PDFViewerLoadDocumentFromResources Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocumentFromResources(
    string folder,
    string fileName,
    string password,
    int pageIndex = 0
)

Parameters

folder
Type: SystemString
fileName
Type: SystemString
password
Type: SystemString
pageIndex (Optional)
Type: SystemInt32

Implements

IPDFDeviceLoadDocumentFromResources(String, String, String, Int32)
See Also

Reference

PDFViewer Class


PDFViewer.LoadDocumentFromStreamingAssets Method

PDFViewerLoadDocumentFromStreamingAssets Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocumentFromStreamingAssets(
    string folder,
    string fileName,
    string password,
    int pageIndex = 0
)

Parameters

folder
Type: SystemString
fileName
Type: SystemString
password
Type: SystemString
pageIndex (Optional)
Type: SystemInt32

Implements

IPDFDeviceLoadDocumentFromStreamingAssets(String, String, String, Int32)
See Also

Reference

PDFViewer Class


PDFViewer.LoadDocumentFromWeb Method

PDFViewerLoadDocumentFromWeb Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocumentFromWeb(
    string url,
    string password,
    int pageIndex = 0
)

Parameters

url
Type: SystemString
password
Type: SystemString
pageIndex (Optional)
Type: SystemInt32

Implements

IPDFDeviceLoadDocumentFromWeb(String, String, Int32)
See Also

Reference

PDFViewer Class


PDFViewer.LoadDocumentWithBuffer Method

PDFViewerLoadDocumentWithBuffer Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocumentWithBuffer(
    byte[] buffer,
    string password,
    int pageIndex = 0
)

Parameters

buffer
Type: SystemByte
password
Type: SystemString
pageIndex (Optional)
Type: SystemInt32

Implements

IPDFDeviceLoadDocumentWithBuffer(Byte, String, Int32)
See Also

Reference

PDFViewer Class


PDFViewer.LoadDocumentWithFile Method

PDFViewerLoadDocumentWithFile Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void LoadDocumentWithFile(
    string filePath,
    string password,
    int pageIndex = 0
)

Parameters

filePath
Type: SystemString
password
Type: SystemString
pageIndex (Optional)
Type: SystemInt32

Implements

IPDFDeviceLoadDocumentWithFile(String, String, Int32)
See Also

Reference

PDFViewer Class


PDFViewer.OnDisable Method

PDFViewerOnDisable Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void OnDisable()
See Also

Reference

PDFViewer Class


PDFViewer.OnDownloadCancelButtonClicked Method

PDFViewerOnDownloadCancelButtonClicked Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void OnDownloadCancelButtonClicked()
See Also

Reference

PDFViewer Class


PDFViewer.OnEnable Method

PDFViewerOnEnable Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void OnEnable()
See Also

Reference

PDFViewer Class


PDFViewer.OnPageEditEnd Method

PDFViewerOnPageEditEnd Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void OnPageEditEnd()
See Also

Reference

PDFViewer Class


PDFViewer.OnPasswordDialogCancelButtonClicked Method

PDFViewerOnPasswordDialogCancelButtonClicked Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void OnPasswordDialogCancelButtonClicked()
See Also

Reference

PDFViewer Class


PDFViewer.OnPasswordDialogOkButtonClicked Method

PDFViewerOnPasswordDialogOkButtonClicked Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void OnPasswordDialogOkButtonClicked()
See Also

Reference

PDFViewer Class


PDFViewer.ReloadDocument Method

PDFViewerReloadDocument Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void ReloadDocument(
    int pageIndex = 0
)

Parameters

pageIndex (Optional)
Type: SystemInt32
See Also

Reference

PDFViewer Class


PDFViewer.SaveDocumentAsFile Method

PDFViewerSaveDocumentAsFile Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public bool SaveDocumentAsFile(
    string path
)

Parameters

path
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

PDFViewer Class


PDFViewer.SetSearchResults Method

PDFViewerSetSearchResults Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void SetSearchResults(
    IList<PDFSearchResult>[] searchResults
)

Parameters

searchResults
Type: System.Collections.GenericIList PDFSearchResult
See Also

Reference

PDFViewer Class


PDFViewer.Start Method

PDFViewerStart Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
protected override void Start()
See Also

Reference

PDFViewer Class


PDFViewer.UnloadDocument Method

PDFViewerUnloadDocument Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void UnloadDocument()
See Also

Reference

PDFViewer Class


PDFViewer.ZoomIn Method

PDFViewerZoomIn Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void ZoomIn()
See Also

Reference

PDFViewer Class


PDFViewer.ZoomOut Method

PDFViewerZoomOut Method

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public void ZoomOut()
See Also

Reference

PDFViewer Class


PDFViewer Events

PDFViewer Events

The PDFViewer type exposes the following members.

Events
 | Name | Description
Public event | OnCurrentPageChanged |
Public event | OnDisabled |
Public event | OnDocumentLoaded |
Public event | OnDocumentLoadFailed |
Public event | OnDocumentUnloaded |
Public event | OnDownloadCancelled |
Public event | OnPasswordCancelled |
Public event | OnZoomChanged |
Top
See Also

Reference

PDFViewer Class


PDFViewer.OnCurrentPageChanged Event

PDFViewerOnCurrentPageChanged Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFViewerCurrentPageChangedEventHandler OnCurrentPageChanged

Value

Type: Paroxe.PdfRendererPDFViewerCurrentPageChangedEventHandler
See Also

Reference

PDFViewer Class


PDFViewer.OnDisabled Event

PDFViewerOnDisabled Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFViewerPDFViewerEventHandler OnDisabled

Value

Type: Paroxe.PdfRendererPDFViewerPDFViewerEventHandler
See Also

Reference

PDFViewer Class


PDFViewer.OnDocumentLoaded Event

PDFViewerOnDocumentLoaded Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFViewerDocumentChangedEventHandler OnDocumentLoaded

Value

Type: Paroxe.PdfRendererPDFViewerDocumentChangedEventHandler
See Also

Reference

PDFViewer Class


PDFViewer.OnDocumentLoadFailed Event

PDFViewerOnDocumentLoadFailed Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFViewerLoadFailEventHandler OnDocumentLoadFailed

Value

Type: Paroxe.PdfRendererPDFViewerLoadFailEventHandler
See Also

Reference

PDFViewer Class


PDFViewer.OnDocumentUnloaded Event

PDFViewerOnDocumentUnloaded Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFViewerDocumentChangedEventHandler OnDocumentUnloaded

Value

Type: Paroxe.PdfRendererPDFViewerDocumentChangedEventHandler
See Also

Reference

PDFViewer Class


PDFViewer.OnDownloadCancelled Event

PDFViewerOnDownloadCancelled Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFViewerCancelEventHandler OnDownloadCancelled

Value

Type: Paroxe.PdfRendererPDFViewerCancelEventHandler
See Also

Reference

PDFViewer Class


PDFViewer.OnPasswordCancelled Event

PDFViewerOnPasswordCancelled Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFViewerCancelEventHandler OnPasswordCancelled

Value

Type: Paroxe.PdfRendererPDFViewerCancelEventHandler
See Also

Reference

PDFViewer Class


PDFViewer.OnZoomChanged Event

PDFViewerOnZoomChanged Event

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public event PDFViewerZoomChangedEventHandler OnZoomChanged

Value

Type: Paroxe.PdfRendererPDFViewerZoomChangedEventHandler
See Also

Reference

PDFViewer Class


PDFViewer Fields

PDFViewer Fields

The PDFViewer type exposes the following members.

Fields
 | Name | Description
Public field | m_Internal |
Top
See Also

Reference

PDFViewer Class


PDFViewer.m_Internal Field

PDFViewerm_Internal Field

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public PDFViewerInternal m_Internal

Field Value

Type: PDFViewerInternal
See Also

Reference

PDFViewer Class


PDFViewer.CancelEventHandler Delegate

PDFViewerCancelEventHandler Delegate

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public delegate void CancelEventHandler(
    PDFViewer sender
)

Parameters

sender
Type: Paroxe.PdfRendererPDFViewer
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFViewer.CurrentPageChangedEventHandler Delegate

PDFViewerCurrentPageChangedEventHandler Delegate

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public delegate void CurrentPageChangedEventHandler(
    PDFViewer sender,
    int oldPageIndex,
    int newPageIndex
)

Parameters

sender
Type: Paroxe.PdfRendererPDFViewer
oldPageIndex
Type: SystemInt32
newPageIndex
Type: SystemInt32
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFViewer.DocumentChangedEventHandler Delegate

PDFViewerDocumentChangedEventHandler Delegate

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public delegate void DocumentChangedEventHandler(
    PDFViewer sender,
    PDFDocument document
)

Parameters

sender
Type: Paroxe.PdfRendererPDFViewer
document
Type: Paroxe.PdfRendererPDFDocument
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFViewer.FileSourceType Enumeration

PDFViewerFileSourceType Enumeration

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public enum FileSourceType
Members
Member name | Value | Description
None | 0 |
Web | 1 |
StreamingAssets | 2 |
Resources | 3 |
FilePath | 4 |
Bytes | 5 |
Asset | 6 |
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFViewer.LoadFailEventHandler Delegate

PDFViewerLoadFailEventHandler Delegate

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public delegate void LoadFailEventHandler(
    PDFViewer sender
)

Parameters

sender
Type: Paroxe.PdfRendererPDFViewer
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFViewer.PageFittingType Enumeration

PDFViewerPageFittingType Enumeration

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public enum PageFittingType
Members
Member name | Value | Description
ViewerWidth | 0 |
ViewerHeight | 1 |
WholePage | 2 |
Zoom | 3 |
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFViewer.PDFViewerEventHandler Delegate

PDFViewerPDFViewerEventHandler Delegate

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public delegate void PDFViewerEventHandler(
    PDFViewer sender
)

Parameters

sender
Type: Paroxe.PdfRendererPDFViewer
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFViewer.ViewerModeType Enumeration

PDFViewerViewerModeType Enumeration

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public enum ViewerModeType
Members
Member name | Value | Description
Move | 0 |
ZoomOut | 1 |
ZoomIn | 2 |
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com


PDFViewer.ZoomChangedEventHandler Delegate

PDFViewerZoomChangedEventHandler Delegate

Namespace: Paroxe.PdfRenderer
Assembly: Assembly-CSharp (in Assembly-CSharp.dll) Version: 0.0.0.0
Syntax
C#
Copy
public delegate void ZoomChangedEventHandler(
    PDFViewer sender,
    float oldZoom,
    float newZoom
)

Parameters

sender
Type: Paroxe.PdfRendererPDFViewer
oldZoom
Type: SystemSingle
newZoom
Type: SystemSingle
See Also

Reference

Paroxe.PdfRenderer Namespace
Send comments on this topic to contact.paroxe@gmail.com